Background bitmap tiling when printing

Hello, I am new to the forums here, and after searching a bit, I found only an unanswered topic dating back to 2014, so with the newer rhino versions out I decided to open a new one.

I had been using Rhino 5 for quite some time and I was using a background image (a sky with clouds, works well with architecture models, set from viewport properties) as a backplate for fast model screenshots - I use this quite a lot either with “print” or with “viewcapturetofile”.

After upgrading to Rhino 6, the image is being tiled in the background, usually in a 2x2 grid. I cannot find an option to eliminate the tiling, and I even tried upscaling the image but the issue persists.

Any ideas?

Hi @dimitrios.skrimizeas,

Can you paste the text from Rhino’s Help -> System Information...?

Thanks,
-David

Here you are:

Rhino 6 SR14 2019-5-7 (Rhino 6, 6.14.19127.17141, Git hash:master @ 5b633aaa430941b76f5789a0ce3bb670ce06947a)
License type: Commercial, build 2019-05-07
License details: LAN Zoo Network Node

Windows 7 SP1 (Physical RAM: 64Gb)
Machine name: UKCRD1LT44811

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M5000M (NVidia) Memory: 8GB, Driver date: 2-27-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 389.08

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-2-2016
Driver Version: 10.18.13.6839
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19127.17141
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please try disabling VRay in Options > Plug-ins page and then restarting Rhino - does the problem persist if VRay is blocked?

-Pascal

I have done this and the problem persists; it also looks like it is not fixed to 2x2 tiling.
The attached image got the tiling at 3x3.

Dimitris

It is resolution related: when I reduce the output resolution it is ok

Your Nvidia driver is pretty old for today’s pace of driver updates. You might try updating it to see if that helps.

@dimitrios.skrimizeas This bug has been fixed in Rhino 6 Service Release 15. Please download the latest Rhino 6 version by going to Help -> Check for Updates....

-David

The latest update (which I was skipping because I don’t have admin rights of the computer) did the trick.
Thank you David

1 Like