Avoiding Broken Edge Lines in Technical, Pen and Similar Displays

I’ve spent a long time trying to answer this for myself but without success so far.

When I look at my model in one of the line drawing type modes such as Pen or Technical the edge lines appear to be interupted at a point where there would be reflections if the view were shaded. I’ve reproduced this in the picture below

These interuptions always seem to be in the same place relative to the camera - they move across the surface of the model when the view is rotated

I’ve tried removing surface reflection from the display modes and have not been able to get rid of them.

I’m hoping there is a really simple answer to this and would be very grateful if anyone could help?

Hi David - I see this as well with a shape similar to what you show. Thanks for pointing that out, I’ll see if we can get it tuned up.



This isn’t a matter of “missing segments”, or fragmented lines… It’s a matter of depth buffering, and that the meshes used to populate the depth buffer are at the same depth as parts of the curves…it happens more often in areas that are perpendicular to the camera direction, because that’s where depth values can turn out to be more “flat” relative to varying surface normals moving away from the camera…if that makes sense.

You can see this same problem in Shaded modes, but we try to bias the curves towards the camera a bit so that it doesn’t happen as often… I can look to see if I can tune this up in the Technical modes…just letting you know what I think you’re really looking at here.

Something you can try on your end is simply increase the quality of the meshing and produce higher polygon counts, making the meshes “more accurate” with the NURBS surface, thereby allowing the curves to also appear more accurate.


1 Like

Jeff, I did mess with that some before making a YT item and even at very low ‘Max distance’ settings, the display did not change, so I tossed out my first theory that that meshes were the cause…


Ok…but I’m pretty sure that’s all this is…I’ll look closer on Monday.

Jeff, Pascal

I did find that toggling the Ground Plane settings on and off had some effect on the number of broken lines. Toggling it off improved things quite a bit

Ground plane on


Ground plane off


The difference is most noticeable on the partially visible balloon on the left

Hi David - thanks - so far, I do not see that here but I can imagine the GP would change the depth of the scene and mess with depth buffering as Jeff mentioned… but enough with my uninformed speculation- Jeff will know.


Yep… The GP forces the far clipping plane out quite a bit, which in turn significantly impacts the depth buffer values and its accuracy.

I haven’t looked into this yet, but my feeling is that I just need to nudge these wires in technical modes…however, the fact that I’m not already doing this, tells me that I may have run into a snag back when I first wrote Technical mode, so it might not be as easy as it sounds… I won’t know until I look.


Jeff, Thanks for letting me know. To help you prioritize things there is no commercial pressure on my part. I can work around the broken lines with some manual bitmap editing and it sounds like it’s not a commonly found problem.

If there is a straight forward fix then fantastic but I thought I should let you know the situation as above

Best Regards