Automatic detail view turn-off [wish]

It seems I work on files that reach 1gb pretty quickly. Often these files will involve Layout sheets with lots of Detail Views and annotation. Usually, these sheets will have most of the objects in the file showing, and that can make the editing in Layout mode reeeeaaaaalllly slow.

If working in Rhino on a small number of objects is like riding a jetski, then working in Layout mode with huge files is like driving a house boat! (On a houseboat, you turn the wheel and about 30 seconds later the boat starts to turn) Well in Rhino sometimes the editing is so slow, when I type in the text editing box, the letters will show up o n e s e c o n d a t a t i m e

My work around is to turn off my detail views layer, zoom around, do my editing, then turn my detail views back on. It works, but is a bit tedious.

It would be awesome if Rhino had a setting to automatically turn off Detail Views whenever a command that wasn’t using them was activated. For example, if I pan and zoom, detail views would turn off so I could navigate quickly. If I edit a text object, the detail views would turn off so this editing would be fast.

I’m not sure if this is the most elegant solution, but I just need to find a way to speed things up a bit. I feel like I’m losing major productivity because my display lag is so long…


Hi @Andrew, For interest… What Video card are you using? GPU can make a huge difference to layout performance, especially if AA etc. is turned on and you have lots of linework.
Have you tried without Antialiasing?. MIchael VS

Hi @mvyess,

I have a Quadro 4000. And as much as I like AA, I do keep it off until I’m exporting a view as it does slow things down even more.


Hi @Andrew, Ok… Just wanted to check if you were aware of the Quadro tuning settings as discussed here:

and also the recommended settings here:
My Quadro6000 was a slug before I tweaked the Nvidia settings
I know this not really a fix for your problem but perhaps abit of tuning can make it bearable. Michael VS

Hi @mvyess,

I have the 341.21 driver so I did have the settings you mentioned. My profile was just set to ‘base profile’. I set it to Advanced Streaming like you recommended. I have definitely noticed a performance improvement. It feels much more responsive, but still slower than I would like.

How is your Q6000 with these settings? Fast?

Hi @Andrew, My Q6000 works smooth and fast for my requirements which sounds asif they differ somewhat from yours, although I do many layouts.
Other tips I can give you is that if you use the Make2d command to create 2D drawings for your layouts, I normally JOIN and GROUP all the curves on each same type layer eg. all hidden linework together, All solid lines together.
Make2d tends to make 100s or 1000s of little lines. Joining them into fewer compound curves tends to lower the CPU load when working with them in layout.
Also I normally lower the tolerance to 0.1 when using make2d. This drawmatically speeds up the make2d process and also results in fewer duplicate lines which are very close to one another. = more speed. MIchael VS