At what zoom level are we seeing tolerance ok?

set to absolute tolerance 0.01mm
relative 1 percent

There is no zoom in mag indicator, and I wonder when I am seeing a visual abuttment, (for when a snap isn’t possible or other reasons…) if its within tolerance and command will work etc.
How big should the 1mm square be on screen , maybe thats the way to judge it.


No need to zoom. If two surfaces or two curves are within the file tolerance, when you run Join they will join into a polycurve or polysurface. If they are not within the file tolerance, they won’t.

Hi, quite right, but I wish to ensure when creating that things will be ok, rather than find later on when any join or other command relying on tolerance is used, they are not and have to find out where its incorrect.


Gcon can be handy for quickly checking curves and surface edges to see if they touch (G0), are tangent (G1), or curvature continuous (G2).

To be clear, the only command that relies on the tolerance is Join.

Also, you can/should always use MatchCrv/Srf to make curves and surfaces continuous. I take back what I said about Join being the ONLY command that uses the file tolerance - checking the “Refine” option on MatchSrf will cause the command to insert additional control points as needed for the surfaces to be continuous within file tolerance.

an example of wondering if visual is enough, or how would I use matchCrv/Srf

I am drawing out an elipse and it needs to be tangent to a curve, in absence of a command for this (see other post) I am zoomed right in and making it kiss the curve, if I see it do so and the 1mm square in grid is 8 inches wide on screen, is that enough to be within tolerance for when I come to cut and join, as join wont occur unless it is, that’s one way, carry on and see what happens.

can matchCrv make the two abutt ?


If the viewport is set to parallel projection you can zoom in and see things that are about a million times smaller than your tolerance setting. If you are in a perspective viewport then don’t bother with zooming to check accuracy - you’ll just give yourself a headache.

Hi, I always use Parallel. I would be lost without it,

Wish it would default to parallel, (any way of getting this ???)

I just wonder at what zoom I am seeing kiss = tolerance met.


The entire point of Match/MatchSrf is so that you don’t have to do this crazy zoom dance you seem to do. Let me put it this way - if you are zooming way in to see if things meet, you’re doing it wrong. Your life would be about a million times better simply using Match. It’s the entire reason Match exists.

As for your Ellipse - try drawing a line from your center point perpendicular to your tangent line. Then think about where your second axis would be (hint, not at 1).

If you are making your own models you can use the template file to start the model with no perspective viewports.
You can put this macro on a button if you encounter a perspective veiwport from a file someone else made:
-ViewportProperties projection parallel Enter

I use a zoom zcale factor of .75. With that one quick spin (maybe 4-5 clicks) of the wheel in and out will give you a pretty good idea if things are going bad.

You can use the distance command and CrvDeviation to check on things that don’t look right.

skyg, in the posted example elipse tangent option thread, it is vital for the item that the one axis is 0 to 1, so that must be my first move, then the elipse must kiss the blue line, and to know how to use Match to get that to happen would be good to see. When I type Match it asks me to select open curve to change, but I have no open curve to do with as the video help shows. I might have two lines that should cross, I wish to see they do or if not by how much they miss. To touch a curve against another as in elipse case etc, .

jim, how does one set up zoom scale factor for the scroll wheel , I dont see anything in help.

Sam, Gcon…sounds promising but it asks me to select first curve near end, in my elipse tangent case (see post on this) I have no end. again if I have two lines that should intersect as in a cross roads, there is no end.


Options > View > Zoom > Scale Factor.
It’s in the help file.
Values greater than 1 invert the scaling behavior.