Assign a material to an object modify the other elements

Is this normal?

Please share the file from your animated gif.

With two boxes created here I am not able to reproduce this.

Please post the result of the Rhino command _SystemInfo.

Hello Nathan,

Yes, I could have specified that this happens on copy objects.
The cube on the left is a copy of a cube on the right, either with the “copy” command, or with the “Alt” key.

AssignMaterial.3dm (461.0 KB)
sysinfo.txt (2.7 KB)

I am unable to reproduce this with your file. Your _SystemInfo shows an older 6.34 version. You should try updating it to the current 6.34 build version: 6.34.21126.11001.

This is how I created the local test file.

Ah! My Rhino user interface and the check for updates command tell me, “Your installation is the most recent available.”

My file is working correctly on your system?

Yes.

Thanks Nathan, I updated Rhino to the version you sent me, but it doesn’t change anything.
Where I am surprised is that this only happens on my system.

The modifications, chamfers, boolean operation do not change anything. But Ctrl + X, Ctrl-V, yes or “Equal” in the properties panel.

(I don’t know the exact name in the English interface)

What does this mean? Cut and paste I understand, but what does the “yes” mean here?

“Égaler” is “Match” in english GUI. It will copy settings from a source object to the selected object(s). I used this on your objects to make them all look the same, but dragging a new material on from the Libraries, or changing using object properties material panel I still am not able to reproduce.

What I mean: “Ctrl + X, Ctrl + V” allows to “dissociate” the materials between them. Je peux ensuite changer le matériau indépendamment de l’autre objet. Or use “Match” with only “Material” selected to “dissociate” the material of the two objects.

At first I thought the object is copied and not the attributes. but if I change the color of the first object, the second is not changed.

Wow, I didn’t know I was writing in French. Haven’t used that since the few years at secondary school back when I was still young and handsome.

Hmm, I still am not able to reproduce the problem you’re seeing.

(Yes sorry, Google IA translation)

I did not know this property and I do not know how it was changed.

image

Replace “SharedMaterial” with false solve my problem.
Thanks Nathan.

Interesting, I wasn’t aware of such a property.