Assembly incompatibility for GalapagosComponents.dll

I am getting the following error, how is it possible?

  1. There has never been a 6.34.21034.7000 Grasshopper version.
  2. I double checked the installed NuGet packages and Grasshoper (and RhinoCommon) 6.34.21034.7001 versions are installed.

Any ideas/help?
Thanks a lot