Artifacts on display


#1

I am getting lots of artifacts on all displays in all render modes.
They disappear when i zoom in.
I cannot select them.


(David Eränen) #2

Hi @JasonP,

Are you using this week’s WIP? Please paste the version number here by going to Help -> System Information. The information looks something like this:

Rhino 6 SR0 2017-7-19 (Rhino WIP, 6.0.17200.20361, Git hash:master @ 34108fbe8968a15147893117e142da706294d7ba)

Could you also post a screen shot showing the bug? If you have a scene which reproduces the problem, could you attach it to this thread?

Thanks,
-David


#3

I didn’t realise you could attach pictures by dragging.

Rhino 6 SR0 2017-7-18 (Rhino WIP, 6.0.17199.12041, Git hash:master @ 9201f554befe8a516130e036d13ce4f65a915cd0)

Windows 7 SP1 (Physical RAM: 24Gb)

GeForce GTX 970/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 382.33)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 5-17-2017
Driver Version: 22.21.13.8233
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino WIP\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino WIP\Plug-ins\MeshTools.rhp “MeshTools”<img


(David Eränen) #4

Interesting. Does this only happen with this file? If not, then it would be helpful to know how to reproduce this.

If this is the only file with this behavior we would need to get our hands on the 3dm file. You can upload it here, or if you don’t want to post it publicly you can upload it via this page https://www.rhino3d.com/upload.

Please write my e-mail into the recipient field (I’ll send it as a PM).

-David


#5

No,It happens with other files,They are rhino 5 files that i have moved to the WIP and have imports from the horror software that is vectorworks.
I exported the VW files to Rhino 3dm.

Uploading file now.

Oops, i sent it to the tech email.


(David Eränen) #6

@JasonP I got the file.

I have created a bug report for it.

As a temporary workaround, type the command name TestGlTessellationShader and change Enabled to Off. This will make rendering slower, unfortunately but it will get rid of the artifacts.

-David