Artifacting

I encounter artifacts in the rendering. Typically occurs with all types of lighting and only a specific set of materials or solids colors being used.

Just a quick image since I’m limited on time at the moment. I’ll have to dig through my archive to search for older renderings that presented the same problem and I’ll post those as well.



Looks like you need finer mesh settings.

I do not believe that is the issue. This is a fairly good mesh. I also maxed out the mesh and the issue persists. It must be related to “reflections” within the materials settings. In this specific model all my custom material works but this particular one. In a different model, every other custom material works fine.

This is just a test model. In more complex models the entire model is affected, which makes post-processing a pain eliminating each pixel or group while attempting to match the scene.

2021-09-30 02_05_22-Polygon Mesh Detailed Options

Artifacting, reflecting tiny speckles (pixelated) or granular circles

No flaws/issues - same exact material setting as above but different color

2021-09-30 00_43_13-Polygon Mesh Detailed Options

Artifacting, reflecting tiny speckles (pixelated) or granular circles

Did you try to disable the most parameters? So far I know you can set unused parameters 0. For example ratio 90 or 180 looks strange, it mean a edge ratio of 1:180 and this are long thin needles. A ratio of 1 would be better for a nice mesh since it mean 1:1. Or set it 0 and the parameter is deactivated.

Only the min initial grid quad parameters seems to be active for the meshing. Is this your goal?

You can check the polycount of the object per _PolygonCount. So far your artefacts follow the polygon mesh and the artifacts have the size of the polygons I would try to get a finer mesh. For example max angle (means max error between curved surface and poly mesh) of 3° should make the mesh more accurate.

1 Like

Yes. I tested with multiple settings. I even disabled all. The artifacts are displayed in the same exact location. If I turn reflections off they do not appear. Particularly in this file.

2021-10-01 03_41_24-Polygon Mesh Detailed Options

Older test renderings, not all are affected, not all materials display artifacts but the surrounding scene does. Affected scenes include solid or emissive materials.

2021-10-01 04_00_57-6480_SLD_ORANGE_MEDPLUS_NL01_NEW_BEAMS_00001.tga - XnView MP



2021-10-01 04_04_07-7488_SLD_BLU_BKT32_HIGH_NL001_00001.tga - XnView MP







Waiting for Chaos Group support to actually show they support their product. This is one reason I would never support Chaos Group poor support and poor values.

At your images it looks like some of your surrounding setups are to contrastful and the low polygon people strengthen artifacts. Did you try the option “max ray intensity”? Also I would check the setup and avoid the bright sources.