ArrayCrv VERY strange - objects get lost on the way


I tried to arraycrv sleepers along a curve…

Result is OK except there are missing sleepers on the way. i dont get how this is possible.

podvaly_kolajnice.3dm (6.9 MB)

i found out it is happening only in roadlike mode. no rotation or freeform does not cause this strange issue missing out some objects on the curve

Hi Ivan - I must be doing something different here - there are no gaps when I run ArrayCrv with these settings:

In green are the sleepers that are created when I ran that here (your sleepers in gray are covering the green ones…):


thats why i say i dont get it because there seems to be no possible reason why just few would be missed out … i am going to try it again and record my screen

i am not making this up :smiley:

The proof:

Yep, I do see this in one spot if I set the CPlane as world top (as in the video), then run ArrayCrv with the roadlike option and a 600.0 spacing.

I tried FitCrv with a value of 1mm on the rail curve (to see if reducing the number of points would help) and it got much worse…

I don’t have problems with either if I explode the first tie (sleeper) - which is a block instance - into a polysurface, so I wonder if this doesn’t have something to do with the block definition or insert point…

Yep, here it looks like any block leaves the gap… weird.
Looks correct in 7WIP, here.


when resolved i will be curious what piece of code was actually the cause because i cant see any pattern or why this should happen at all. its really an arbitrary weird kind of bug…

Blocks are always “special”… :stuck_out_tongue_winking_eye:

1 Like

i think there is quite a room for improvments. blocks are powerful feature and should be absolutely reliable when working with. this was my second issue with blocks in a day. and all of that emerged during just basic work on real model using standard workflos.