ArrayCrv doesn't accept feet & inches


#1

(i’m under the impression the mac beta forums will be relocating to discourse-- hopefully i’m not being premature with this post)

the ArrayCrv dialog box is different than most other commands which accept distance values. It’s also different in that it doesn’t recognize feet&inches:

entering 1.33333 doesn’t space them accurately (maybe it would if i tightened tolerances? the solution, if you’re using feet as the unit, is to switch to inches and enter 16 (in this case)

[edit- it’s possible i pointed this out some time ago… can’t quite remember… if so, i’m just bumping the subject then :wink: ]


(Brian James) #2

Thanks Jeff for this report.

I just tested this in the latest build 460 and also tried in a file using feet/inches for the units and this ability is still missing. I filed this as MR-657 if you want to ask about it again.

I’m not sure about the forum switch decision but you’re probably right.


(Marlin Prowell) #3

You can work around this by using the “dashed” version of the command -ArrayCrv. Also, you need to enter the distance without the dash. Use 1’4" as your distance.


(Steve Baer) #4

That is the plan


#5

oh… nice
yeah, that’s the type of command dialog i would expect to see.

what’s the difference (in general) between a dashed command and non-dashed?


(Pascal Golay) #6

Hi Jeff- in general, in Windows, dashed commands run command line versions of commands that normally pop up one or more dialog boxes, But in some cases these just expose more options than the regular command. I do not see them working to suppress dialogs at the moment in MacRhino but there may be something else to do there.

-Pascal


#7

ah… ok
thanks for the explanation


(Pascal Golay) #8

It’s working, just not, it looks like, for -Properties, which was what I happened to test.

-Pascal


#9

yeah, i tried out a few things earlier and got a better understanding of the dashed commands.

some of the commands which have the dialogs shown in the top post are sweep1, sweep2, blendcrv , blendSrf… a few more… (with -blendSrf being one which has less features … it doesn’t have the sweet sliders)

but i can now see if working from the command line alone (no floating command dialog on mac) then nothing will pop up if using the dashed version of the command…
probably also useful in macros?


(Marlin Prowell) #10

Exactly.