Arqishape 3d / python error / Solution exception:Method not found


On my updated Rhino 6 this error prompts in the Staircase 2D Design ArqiShap3D | Food4Rhino comand:

  1. Solution exception:Method not found: ‘Double Rhino.RhinoMath.MetersPerUnit(Rhino.UnitSystem)’.

Googled it Python Error "Solution exception:Method not found:rhino.Plugins.Plugin rhino.Plugins.Plugin.find(system.guid)" - Grasshopper an tried it with changing Units in Rhino, but nothing helped.

thanks and best regards,


Hi Tom,

I didn’t yet check it, but that problem probably occures because the method mentioned in the error does not exist in the version of Rhino you’re using and that’s an error on my part. I was using Rhino 6.11 while developing ArqiShap3d until the last versions but due to some problems, I had to switch to using Rhino 7. When using Rhino 6, it wasn’t possible for me to use a method which hasn’t been added to Rhino library until the version 6.11 but when I switched to using Rhino 7, I had to pay special attention to not using these methods. I think I missed the one you came across to. I will check the source code when I can, if it is easy enough, I can solve the issue and send you the fixed version.

Hi Ömer,
thank you, for your fast reply.
Today I had a 4 hour research for staircase grasshopper scripts and yours seems to be by far the most attractive one. What a outstanding job! So a fix for six (6 SR35) would be great for sure.
I´m so curious which method you´re using to generate these nice windings seen on YT. Is it some way like in the picture below?
best regards,

Hi again,

Thanks! The staircase component works well for simple cases but can’t quite solve complex staircase designs. Also, it can’t design landings yet… Hopefully in the future though. I hope you will find it useful for your work.

I was able to fix the issue very easily. I had to change only one method. I am uploading the file here for you to check, if it works for you as well, then I will upload it to Food4Rhino.

The staircase design component in ArqiShap3d, doesn’t use a method like the one you’ve shown in your post. Maybe the method you’ve shown could work better, but to be honest, I didn’t know the details of how it worked back when I was developing the staircase component. I would like to check it out in the future but I can’t give a date to when that would be…

The staircase component in ArqiShap3d does these in order:

  1. Draws the other side curve and the center curve,
  2. Divides the center curve to equal tread widths and gets the division points,
  3. Draws each step curve from these division points on the center curve (with the normal vector on the curve at each point),
  4. Cuts the side curves to pieces for each step,
  5. Checks for short side curves for each step,
  6. If there are any short side curves, then checks the adjacent step curves (of these side curves) for short curves,
  7. Checks for room to grow towards each side of the adjacent short step curves,
  8. Attempts(!) to grow the short side curves towards both directions if possible.

As I mentioned, this process can’t solve complicated cases, and sometimes can’t solve even some of the basic ones. But I was able to work it out for some of the basic cases I have tried. You can check how well it worked with the “Points For Dimensions” component like I’ve shown it here in this video.

Hope this is useful…

arqishap3d.gha (404 KB)

1 Like

yes, it runs flawless now. I Got quite good first results after a short play around.
Thank you very, very much!
Best regards.

Hi Tom,

Glad to know it’s working well. If you encounter any problems or have any suggestions, be sure to post it here, I will do my best to reply. I am working on other things at the moment so I might not be able to work on the tools right away, but I will definitely take a note for the future.

Thanks for your feedback. Glad I could help.

1 Like