ArionLive4Rhino Broken too


#1

…seems Arion4Rhino is broken too. I just tried to install it and nothing shows up in the interface. Fails when I manually try to install the pluggin. Anyone using it successfully with SR8?

Sure wouldn’t mind some sort of comment from McNeel on what is the plan to keep things working. Rhino use to be my app of choice for rendering as it had so much to choose from. It was predictable, solid and I got my deadlines met. Now, it feels like one big moving target.


#2

To add…it would be nice to be notified by Mcneel that some of my pluggins were about to be broken once I installed a new SR. And if you don’t know that something is going to be broken, how can it be released via the automatic new version function. I though betas were the place where this sort of thing occurs and not in a full production release.


(Andrew le Bihan) #3

Paul

I know you’re frustrated, but while we test a lot of plug-ins when we release a new service release, we can’t test them all - and we certainly can’t test them on all possible configurations. We have not deliberately broken anything that might affect Arion, nor any other rendering plug-in.

You really need to contact Random Control on this. It really isn’t something we can help very much with.

  • Andy

#4

You have no idea how frustrating it is. I have contacted Random Control already. But when you say “It really isn’t something we can help very much with”, isn’t 3rd party development important enough to McNeel to ensure any actions which broke something get resolved quickly?


(Andrew le Bihan) #5

Yes, it is. And I can assure you that if we find that there is a problem that we need to fix, we will deal with it very, very quickly. However as of right now, I have no way to repeat this issue.

  • Andy

#6

Don’t you have Random Control’s pluggins on your machine? I would assume you would. Can you tell me where I can download SR7? If I can do that (re-install it safely) I will turn off the automatic upgrade and get my work done.


(Menno Deij - van Rijswijk) #7

Download SR5.7 it here http://files.mcneel.com/dujour/exe/20131207/rh50Release_x64_en-us_5.7.31207.07545.msi


(Andrew le Bihan) #8

Paul

I don’t have it. It is not always the case that 3rd party developers give us their plug-ins to test with.

  • Andy

(Andrew le Bihan) #9

Paul

We have someone here who has Arion, and it loads. Which version of Arion are you using?

  • Andy

#10

I’m using 2.4.4


#11

It’s the plugin developers responsibility to test the release candidates and keep plugins current.


(Andrew le Bihan) #12

Ricardo

To some degree this is true. However, if we’ve broken something that we have guaranteed will work a certain way, we have to fix it.

We’re working on this. As fast as possible.

  • Andy

(Andrew le Bihan) #13

Paul

I’ve been testing Arion for Rhinoceros in SR8 for the last hour or so - it works perfectly here.

RandomControl mentioned that you contacted them and that you had it working. Is this correct?

  • Andy

#14

Yeah, seems to be bonehead user error. I’ve been testing it some and seems to be fine. The best I can figure out is that when it didn’t install automatically, I went to pluggins and tried to install manually. What I didn’t see with that is it pointed to the 32 bit version (which got installed with the 64 bit one) and I assumed that was the 64 bit one. And nothing loaded.

Once you mentioned it was working in the shop I redid all my steps and got it to work. Both 2.4.2 and 2.4.4.

Sorry for all the ‘drama’. I still haven’t figured out how to get the 32 bit Fry pluggin working in my 64 bit Rhino version. That was working in the SR7 and stopped as soon as I loaded in SR8. But that machine is in Florida and I’m no longer there.


#15

Hi Andy,

I have followed both T-Splines and the Maxwell Render plugin development pretty closely, and I know they kept on top of it all times. Each and every RC.


#16

Getting a 32 bit Fry plugin to work on your 64 bit Rhino sounds odd. Are you sure you didn’t have a 64 bit plugin? Or that you accidentally had 32 bit Rhino?


#17

I know it sounds odd but it worked. I had the pluggin for Rhino4 installed and used… and when I updated to Rhino 5-64 bit that pluggin was available within the interface. I’ve used it ever since in V5 - 64bit. It is available on Rhino 5-32 bit but I never use that. I hadn’t used the pluggin for a week or two and then updated to SR8. A couple days later I tried it but it wouldn’t load. I can use Arion4Rhino and it works well.


#18

Ok, thanks for the info :smile: