Area component extremely slow in GH

Hello, i have some definition which is dependent on area component. It takes minutes to calculate 56 cylindrical surfaces which makes definition extremely heavy.
In rhino the same areas can be computed within miliseconds.

Why does it take so long? is it such inneficient piece of code or there is something more behind it?

so i found out where the problem is…

typical far from origin…

I made a simple test. The same geometry at origin and the same geometry very far. Difference is huuuge

that is interesting, thanks for pointing out!
I noticed this slow calculation before and could not explain it… what solved it for me was switching to mesh area, which is fine as long highest precision is not a concern.

1 Like

i am workarounding it right now that i move all the geometry back and forth with a vector which is based on actual position of construction site.
i developed my script for BIM classification i tested it only with few objects but when i really used it for real project it was unsuable at all

so it helped maybe 400x times when i do move compute move back than computing at place. maybe even better then using mesh area instead

Post an example

Thanks for that report, Ivan. I’ve issued RH-57394…

1 Like

sorry i already deleted my test file but look what wim filed below as an issue. you can replicate it simply with a box. it is definately a bug because even if coordinates are large it cannot cause such dramatic slow down

so my workaround works but now i realized its not perfect. now i have some really distant geometry in grasshopper pipeline which cause display clipping in rhino… i resolved performance issue as a trade of for display issue :frowning: hopefully area component will be fixed soon so i can undo my temp workaround

I guess you don’t need the geometry that is copied to the origin to be visible? If it’s not visible, it shouldn’t cause clipping…

it seems even undisplayed geometry affects bounding box of rhino viewport. when i zoom extents with gh open it captures also origin. when i close grasshopper it works well… i have no visible geometry in grasshopper… maybe i have some nodes in clusters. is there a way to rightclick on a node and disable preview, but do it for all the selected nodes at once? i can try disabling all the nodes inside clusters and see if it helps

ok middle mouse click and click … i never used it before

nope. i have previewed off every single node i have in my huge definition but it doesnt seem to help that zoom extents in rhino still captures origin. i tried with empty gh file and it works well so it must be something with the fact there are virtual objects in grassshopper definition moved to origin even they are not previewed at all

Hi - I’m not seeing any cropping with my simple box example (and it doesn’t matter if the close-to-origin box is being previewed or not)
If you can provide a sample that shows this I will file an issue for it!