Archicad export (gsm, lcf) suddenly disappeared

I have a problem. On a single machine, on the Rhino 5 SR9, the ArchiCAD GSM and LCF options have disappeared from Save As menu. It happened only on a single machine. I tried to reinstall the Archicad GDL exchange plugin in, but it didn’t help. What’s up?

Just a few question, I’m afraid…
Is the plugin enabled in the plugin manager? Does it make any difference if you run Rhino as administrator? Are there any messages when reinstalling? Are the other machines on SR9? Any reason not to update to SR13?

The plugin doesn’t even show in Plugins, so I guess it isn’t enabled. It doesn’t make any differences when ran as admin. I tried that first, and just now with no avail. There are no messages. Yes. All machines were on SR9, however, this is the only machine which had the Windows 10 anniversary update done, and with latest Archicad19 update. Prior to those 2 updates, everything was working on this machine. Maybe it could have something to do with that?

PS I just updated to SR13 on this machine. Nothing changed.

PPS I’m a bit confused with the import/export plugin right now.
This is the thing I have to install, right;
"The Rhino GDL converter". When I try to reinstall it, it says, it has been already installed, but in …program files/graphisoft/GSM-LCF exporter… And when I check, it’s not there. !?

I would check and see if you can find GSM-LCF exporter for Rhino 5 in your Windows’ Control Panel\Programs\Programs and Features list and uninstall there.

Also, search your HDD for any RhinoGSMExport.rhp files and delete those.
Then install again - perhaps using a different folder (default appears to be C:\Program Files\GRAPHISOFT\GSM-LCF exporter for Rhino 5).

There is no GSM-LCF exporter in Programs and Features. So I can’t uninstall.

Right now I have no choice to choose where to install, because it says it’s already installed. I couldn’t find the “RhinoGSMExport.rhp” file on my computer…

Arghhh…this is a mess.

PS Could this be bypassed by copying the plugin to the certain rhino plugin folder? Could somebody please share the plugin files.

Sounds like it, yes.
I suppose you could try to search the registry to see if there are traces that you could delete.

Else, in the attached, I have compressed the rhp file and all that seems to be necessary to go with it. You could unpack this and drag-n-drop the rhp file into Rhino and see if that helps.
test.7z (5.3 MB)


I guess that’s what I did in that zipped file.

Thanks. I’ll try and let you know! Cheers


I copied the files into Rhino/Plugins. And then I enabled the plugin in Tools/Options/Plugins, and now it works.
I don’t know what happened there. Something probably went wrong with the Windows 10 anniversary update. This is not the first issue with software after the update. So watch out.

Anyways, thanks, a lot.