Arc button flyout keeps trying to move


(Declan Halpin) #1

For some reason, the Arc toolbar keeps trying to move the top button to inside the flyout toolbar. Only the arc toolbar does this…

ArcToolbar.zip (78.9 KB)


#2

Hi declan,

maybe you´ve changed the link to behaviour. You can change it back using SHIFT + Right click on that button and set the Linked toolbar to “(No Link”). If i set mine to arc, i get the same error as you are showing:

If this does not solve it, try to either open the “Arc” or “Main” toolbar using the _toolbar command, then locate the button and try to change the link toolbar behaviour as described above.

edit: also disable the “Float to top” setting so it is unchecked.

c.


(Margaret Becker) #3

It sounds like the Float to top setting is on for this toolbar.


(Declan Halpin) #4

Float to top is not checked.

Linked Toolbar is set to Arc, but if I set it to No Link, I don’t get the flyout for other Arc types. Other buttons have Linked Toolbars and have no problem.

Also, I just checked V4 and the Arc button is set to Linked Toolbar = Arc, with no problems.


(Declan Halpin) #5

Also - I should add some clarification: The error message only appears when I LMB (and hold) then move the pointer over the flyout. If I release LMB before moving over the flyout there are no issues. It’s just a shortcut I seem to use where I choose the desired button from the flyout with an “onRelease” action.


#6

From your video, I see that your arc 3 point button (second from left in the toolbar) also is linked - that is not standard (mine is not that way). Pull out the toolbar completely (i.e. tear it off so it’s floating in the workspace) and then Shift+Right click on the arc 3 point button and set the bottom dropdown menu to “no link”…

–Mitch