AO Arctic mode some objects shaded very dark in screengrab / print

Hi! I’ve been having a problem for a while when using any AO viewport like arctic mode. It tends to happen on larger more complex models, but some objects will shade much darker than those next to them when I take a viewcapturetofile or print. If I use the windows screen capture tool theres no issue, and the viewport shows everything correctly for the most part, with intermittent dark shapes. Bringing up the print dialog etc shows the dark parts though.

I just tried updating to the current candidate but the problem persists.
Some blocks seem to be immune to the effect strangely but others are not. Its all pretty random, I tried flipping surface normals and pasting parts into new files etc to no luck. most of the parts in this model having issues are closed polysurfaces.

The biggest problem Im having is that Im using details on my layouts with arctic mode. They look great, but are randomly having chunks of the model go dark which makes them unusable as its pretty confusing what your looking at in some cases.

Here is a screencapturetofile:

here is a screen capture using windows snipping tool showing the difference between my monitor and what rhino is capturing:

here is my system info, Others in my office have had the same problem, and I’ve tried my files on other machines as well…

Rhino 6 SR15 2019-5-28 (Rhino 6, 6.15.19148.13161, Git hash:master @ ae191a06e4addc9964c3f4231a3312f38d4153d0)
License type: Commercial, build 2019-05-28
License details: Cloud Zoo. In use by: Nick Cross ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-7133F6M

Hybrid graphics system.
Primary display: NVIDIA Quadro K4000 (NVidia) Memory: 3GB, Driver date: 1-11-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX TITAN Black (NVidia) Memory: 6GB, Driver date: 1-11-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 417.71

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-11-2019
Driver Version: 25.21.14.1771
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Users\Nick_Work\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7030.16466\RealDrawings.rhp “RealDrawings” 1.0.7030.16466
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19148.13161
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Users\Nick_Work\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\4.0.0.101\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino” 4.0.0.101
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Thanks!

-Nick

Hi Nick - are the objects all closed?

-Pascal

Hi Pascal!

It seems to be a bit random, this image is a mix of some closed some open surfaces. heres’s some labled…

interestingly, if i explode the blocks they also become dark, but this is pretty random, IE if i make those dark ones a block they stay dark. Cant seem to find any rhyme or reason to it.

exploded blocks:

Hello - can you export one or two of the correct-looking and too-dark objects and post here or send to tech@mcneel.com?

-Pascal

Sure thing, here is a portion of that model. Also to note, sometimes if you rotate an object it will print normally, like that soffit rotated 90 prints fine.


renderissues.3dm (10.7 MB)

The same problem seems to be effecting rhino 7 wip as well btw.

Thanks!

Hello - see what happens if you set the mode to defaults, and then enable/disable the ‘Advanced GPU lighting’ setting…?

-Pascal

no change with those. this is with GPU changed and settings set to default

Yeah… I can reproduce this now… Thanks, I’ll get it on the pile and I do not have a good workaround other than a temporary Explode, which seems to sort it out, here. Still poking at it…

@nscross - fyi - https://mcneel.myjetbrains.com/youtrack/issue/RH-52965

-Pascal

Ah interesting, thanks. So you exploded everything in the model? Thats the only way i just got it to work, only exploding the bad objects didn’t seem to fix it…

Also on a side note, I’ve had a few times, mostly in interior room models where the shadow camera clipping plane kicks in even though it is set to off in the display options:

have you run into this one before?

The AO display modes have really been helpful overall though, they’ve made a real difference in my work flow!

Thanks for the help!