Anyone using V-Ray 5 in Rhino 7 for production work yet?

hi all,

I upgraded some of our V-Ray seats to Vray 5 today. Yet speaking form past experiences with V-Ray new releases + Rhino 3rd. party rendering integrations I’m hesitant to install it yet.

Has anyone tried this combination yet? if you can share your experience we’d really appreciate it.



I downloaded trial version too but without insyalling it yetas I found a post talking about clash between visualarq and Vray 5 so I’m waiting but the trail version doesn’t

thanks @huss191998, thanks for letting me know. We don’t use trials and we don’t use Visual Arq. I’d love to hear about uses for industrial design renderings.



I’m using Vray 5 hotfix1 & Rhino 7 for production.
Fast, relatively stable (some of my problems may be caused by starting in Rhino 6 & Next, then continuing with V5 & R7). Overall, problems seem to be reduced with hotfix1, I haven’t had time to explore all the new features.

1 Like

I tried out Vray 5 hotfix 2 in Rhino 6 and had lots of problems with crashes. Since I installed it I also can’t render in Vray from Grasshopper any longer. It always gets stuck at “Exporting”. Uninstalled Vray and went back to latest 4.2 - now it still always shows “Exporting” when trying to render from Grasshopper. Using “Render in Rhino” still works.

So yeah, still seems quite buggy.

updating prior post (sorry I couldn’t find the edit feature).
Rhino 7 sr1 & Vray 5 hotfix1.
I’m getting random system freezes typically right after starting a production render (rtx, cuda or cpu).
I wait a few minutes, then hit reset button, reboot, back to work.
Happens with new files created in R7 & Vray5, or updating older files (R7 & Vray next).
Doesn’t matter if its a small/simple file (no fur), or larger complex file, sometimes 1 freeze per day, other times a few in a row then it goes away.
Sometimes first render freezes, other times it’s after working several hours and successfully rendering dozens of frames.
The only action that may be triggering this is closing current Rhino file, opening another to use copy/paste, then back to original Rhino file.
During the fall I evaluated with Rhino6 & Vray next, seemed stable. But I was doing simpler things.

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Commercial, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 (NVidia) Memory: 8GB, Driver date: 12-11-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.89
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-11-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Thanks all for reporting this. ChaosGroup seems to continue to be consisted here: always releasing things that are not ready for production work, without regards to its users. Good thing we have learned not to rely on them, so we don’t get disappointed :rofl:


1 Like

Haha, for sure. I keep coming across bugs when trying to use it. Just now somehow it had deleted ALL my materials?

Safe frame doesn’t work consistently between GH and Rhino, so with the same camera you get a different view.

Rectangle lights aren’t the same in GH and Rhino

In GH you can turn on Exposure, but cant change the actual value of Exposure.

No depth of field in GH

Trying to load a vrscene file in GH - not showing up

No batch export of vrscene in Rhino

man, the list goes on.

I really wish they wouldn’t keep pushing new versions (Version 5 for Rhino came out before most others), yet is still full of bugs. It’s really starting to make it too much work to set up and then in the end it fails because of some bugs.

1 Like