Anyone Else's Armadillo Broken?

I don’t have time for this not to work today…

@Jarek Not sure if it’s just me.

Rhino 6.19.19295.1001, 10/22/2019

Hi Eric,

I am still on SR18, so don’t know anything about things being broken in SR19…And nobody else reported problems.
So what happens? You just type the command and it doesn’t run?
Did anything change in your system / Rhino (just updated SR, etc.).
Sorry I am not aware of any issues currently so will need to investigate to be able to help.
Please let me know, or contact me via PM

–jarek

It can’t see it doing anything. It immediately returns to “Command:”

I haven’t changed anything, I uninstalled and reinstalled, and I’m trying to figure out how to get back to SR18.

Can you try installing latest SR20 candidate? There was a problem with one broken RhinoScript method in SR19 Unit conversion broke changed? Vb scripts no longer work
Which MAY affect Armadillo and its supposed to be fixed in latest SR. I would start there… if you can.

-j

I get a compatibility check and then nothing as before.

I just tested on my laptop with SR19 and all works fine here…
I have not seen this before with Armadillo, but next thing I would try is to not only uninstall the plugin but wipe all Armadillo entries from the Registry, and try installing again.
Let me know if you need detailed instructions how to attack it…

This is SR20, right?

Here I would go to (via running RegEdit):
Computer\HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Plug-Ins\ and search for anything “Armadillo” and delete all of the plugin info.
I would also delete and Armadillo.rhp files you can find in Rhino Plugin folder locations, delete them and then try installing it again…

So far I have no other ideas…

6.20.19310.3081

I will try uninstalling again and wipe the registry entries this time.

1 Like

Armadillo.rhi (594.6 KB)
I recompiled your version again but nothing really has changed so the one you have should be exactly the same… Please try clean/registry wipe install and we’ll see what happens.
Also, how about _ReplaceArmadilloPanels command, same thing? Please test that one as well whenever you can, it’s the same plugin.

–jarek

I tried replace panels earlier and experienced the same issue.

After un-enabling plugin, closing Rhino, deleting the folder from C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins (and V5), and removing the registry entries (and V5), this is what I get with the rhi installer.

Nothing makes it into C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins, but I found this searching registry again:

If I execute the rhp file it opens V5 and says the install ID is already in use.

If I drag n drop the rhp file into V6, it adds it to the plugin list but then back to doing nothing.
image

It does work in V5 and I still don’t know to downgrade to SR18 to see if it will work in V6.

image

Thanks for trying all of the options. I would try to roll back to SR18 (not sure how though, I did it in the past…maybe @Pascal can help?) But I am afraid somehow your plugin entries got messed up in the Registry or plugin folders and that’s why it is acting up. I have not seen this before and not sure just yet how to fix it except for trying to wipe clean everything (Registry, plugin folders) which I guess you did try already. Let me look into it a bit more but if you have any other ideas what to try please do as well.
As I said nothing that I know of changed and did not get any other reports with this problem. Sorry! Hope we can make it work again.

–jarek

One more idea - I DID see this message once from the user (initialization failed).
It was because they had multiple copies of Armadillo.rhp on their system. When they removed them, it all worked fine.
Maybe try searching your HD for all Armadillo.rhp and delete these as well ?

Okay, I wiped from disk and reg again. Used 7zip to extract rhi -> rhp and went to Tools -> Options -> Plugins -> Install and selected the rhp. I happened to notice RhinoScript was not loaded

@pascal BUG: running a script with RhinoScript unloaded returns nothing and confuses and frustrates the crap out of customers on a deadline.

Enabled RhinoScript, restarted Rhino and I get a blocking message.

Thank you @Jarek for the prompt replies. Turns out it was nothing to do with Armadillo. I did it all again with RhinoScript loaded and it worked.

Still no reply from anyone at McNeel.

Ugh… great, glad you figured it out!
Part of the reason I am reluctant to have WIP7 (not sure if you have it) is that RhinoScript plugin gets randomly unloaded and corrupted. Maybe it is solved by now but I was burnt a few times by it on deadlines so trying to stay away for now.
Again, happy it is working again for you now.
Cheers-

–jarek

Hi all. I was experiencing the same error today when I tried to install Armadillo and I went through all the troubleshooting that was mentioned in this thread. I’m not sure if this helped but my RhinoScript plugin was unchecked so I ticked it back on and then I had to manually browse to the Armadillo plugin that you downloaded and drag&drop it for it to work. I had to redo it after closing the Rhino instance and relaunching it for the changes to stick. All seems well now, so I hope this helps someone out in the future.

Hi Jess,

Are you also using Rhino WIP? From what I’ve seen running it and v6 often unfortunately messes up RhinoScript plugin in V6. Glad you sorted that out.

@pascal - it’s been common thing recently with more users experiencing their RhinoScript plugin unloaded. Not many are as resourceful to search here and have it fixed and it is a problem for RhinoScript-based plugins. I can only guess many would download from Food4Rhino, type command, nothing happens, then they just move on…
Maybe there could be some sort of a warning or check if RhinoScript is loaded while someone is trying to run RhinoScript plugin command, instead of just nothing? Are you aware of this problem still existing with WIP and Rhino 6?

WIP was installed before on this PC before it got donated to me. I didn’t do a clean Rhino install if that makes any difference so I just logged in and carried on with my work.

1 Like