Anyone else having 100% util on GPU with latest WIP?

This happen to anyone else? No command running, small 1MB file, and the display starts stuttering?
I thought it was just the autosave running until the whole thing came to a dead stop.

Trying to save now, but it’s totally non-responsive and mem usage is climbing.

version number?

help>about rhino

and please run systeminfo in the rhino command line and paste in reply-

It’s the latest build. Couldn’t check for exact number earlier while I was waiting to see if it came back. It did not.

Rhino 7 SR0 2020-6-2 (Public Build, 7.0.20154.14355, Git hash:master @ e6c4f6454b96fbf94100810710d49300518d1a88)
License type: Commercial, build 2020-06-02
License details: Cloud Zoo
Expires on: 2020-07-17

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA TITAN Xp COLLECTORS EDITION (NVidia) Memory: 12GB, Driver date: 4-7-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.92

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-7-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\XNurbs (80be33b0-13b2-4ac4-9c77-03829214f9e9)\\XNurbsRhino.rhp “XNurbs”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

only thing I see is xnurbs… try disabling that temporarily and see if your gpu load goes down…

It only happened the once. I wish I could tell you how it started, but I didn’t think too much about it at first.

I know for certain that I didn’t use XNurbs on that model, though.

ok, so you are not seeing that happen anymore?

if it happens again, please let us know-

I’m used to my hardware running Rhino. It’s always been very smooth. I haven’t had an issue where it won’t recover, but I keep having a very low stuttering frame rate and max GPU usage.

Updated to latest build (7.0.20168.13075, 6/16/2020), and it’s still an issue.

let’s try a graphics card driver update- I know you have a pretty recent driver, but this is a newer card and nvidia released a new driver for it already.

also go to tools>options>view>open gl and verify that your card is listed in the open gl specs-

also make sure your card is set to use max power

Well, it’s a 3yr old card and I have it set to auto-update to the latest ‘studio driver’. There is an option for latest ‘game driver,’ which I’ve always interpreted as ‘minimally tested hotfix.’

I always follow the old wiki for nvidia settings including max power:

are you using the workstation app dynamic streaming profile?

if so try the regular base profile and see if there is a difference.

@jeff may have more ideas?

If this happens again, please look at the command line and see if anything is getting printed out… Any kind of stuttering is usually indicative of something trying to get done over and over and over again, failing every time… like trying to create a render mesh but failing, so Rhino then tries again…and so on. In that case you would see “Creating render meshes…” constantly flashing in the command line. I’m not saying that’s what it is/was…just an example of what to look for.

Also, while it’s happening… try hitting the ESC key multiple times (stand on it) to see if it cancels whatever is happening… I would also keep track of which display modes are currently active, and if setting all viewports to Wireframe makes the problem go away.

Other than that, I have no silver bullet for this, since I’m not really sure what took place.


1 Like

Command line never shows anything happening. It seems to happen randomly when manipulating the viewport. I haven’t seen it happen while a command is active. (BTW, I have a space mouse).

When I notice the framerate drop, I glance at task manager and see GPU usage in the 30% range. If I stop manipulating the viewport, GPU usage either drops to 0% or runs to 100% for 5 to 10 minutes.

What really stinks is that my auto-save is not running every 15 mins. When I check the timestamp, it’s 20, 30, 40 minutes old. Makes it a tough gamble. How long do you wait to see if I can save 40 minutes of work?

as a test, try disabling the space mouse…does a regular mouse work better?

It’s very intermittent and hard to replicate, but I’m starting to suspect it has something to do with the “TsShiny” display mode. I haven’t got regular “Shaded” to lock up yet, but I’ve only tried it for 20 mins.

Space mouse uses less GPU than mouse (10% vs 40%), but both stutter with “TsShiny.”

TsShiny.ini (331.3 KB)

ahhh. were you a tsplines user?

If so, then that view mode in v6 should be deleted.

That’s been my shaded mode for the better part of a decade. I’m fairly certain I’ve customized it from the stock TSpline settings.

Either way, the last two WIPs shouldn’t spike to full GPU usage when the viewport isn’t being manipulated.

right, but you are the only person reporting this so far, so I’m assuming it’s machine specific…trying to eliminate outside influences to kill the problem, then we can add them back 1 by 1 to see which one is the bad actor…

Well, it happened yesterday with the stock “Shaded” mode.

It’s very inconsistent and hard to reproduce, but my gut says it has something to do with the amount and complexity of history. I feel like:

  • It’s uncommon at the start of a model
  • SaveSmall and restarting the WIP does not make it go away
  • It’s uncommon after you break all history to Join/Boolean finished models.

If that’s the case, when it starts, try purging history and see if it resolves.

1 Like

I had the same problem, few days ago untill now. I’m using version (7.0.20182.13135, 30-Jun-20) now on my GTX 1060 VGA