Any advise for discontinuity in exported objects for rendering(mac)

I’m trying out external standalone render sw in mac.
Curently checking blender. Importing in dae or 3dmax.

I have trouble witk discontinuity in the surface where I used matchsrf in rhino.
In the built in rhino render and environment map the discontinuity is not as bad. It’s more like a sharp bump than discontinuity since it has been matchsrfed.

Is there settings when exporting to other render software which would be good for this kind situation?

For keyshot the discontinuity is not as bad as blender.

I bet you’re seeing weld angle tolerance differences in the mesh. ExctractRenderMesh in Rhino and then use the Weld command to try alternate angle tolerances. You can also do this in poly-modelers like Blender. Post a file and screenshots if you still need help. I’d also recommend OBJ as the format to transfer.

Thanks! Will try it out.
Diving into the world of meshes.

Tried out the welding and it worked!
From Bottom up, Polysurface, extractrendermesh, weld 3, weld 10, weld 20


Angle tolerance of 3 didn’t seem to do much. Bumping up to 20 made it really smooth.

Some questions:
Is there a recommended limit as to how much the angle tolerance should be?
Thinking 20 might be too much if I have details with edges(though I don’t have at this point) it would be smoothed out.
Also does E-map show how the surface changes when doing weld in meshes?

Also attached the file.
(I should recreate by using removemultiknots in between making surface which I keep forgetting to do…)
Shears_handle_v6.3dm (1.5 MB)

Not really, it depends on the form in my opinion. Here’s how it works…
http://docs.mcneel.com/rhino/5/help/en-us/commands/weld.htm

Emap has it’s own analysis mesh which can be adjusted in the emap dialog but if you give it a mesh that’s what it’ll use. The way Rhino shades the mesh is not the issue in many cases though… it’s how the app you’re going to shades it, especially when there are overlapping verts. So I’m generally checking the exported mesh in the modeler I’m heading to often in the beginning of a project.

Thanks for the clarification.
I’ll also try out other option to fix the meshes.

It seems removing multiknot in the surface also helped with the discontinuity.