Anti Aliasing

Anti-aliasing still doesn’t appear to work on my setup. In Preferences->OpenGL it allows me to select 2x anti-aliasing but it doesn’t have any affect. I’ve attached a screen shot of a shaded view when using 2x anti-aliasing. My Mac is pretty old - a late 2008 MacBook Pro but it does have 512mb of graphics ram even though Rhino only reports 256mb, which is maybe the problem.

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-06-10 (515)
OS X version: Version 10.8.5 (Build 12F45)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro5,1
Processor: Intel Core2 Duo CPU T9550 @ 2.66GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9600M GT 512 MB
Memory: 256 MB
Screen size: 1440 x 900
Displays: Color LCD

Third party kernel extensions
com.parallels.kext.prl_usb_connect (7.0 15107.796624)
com.parallels.kext.prl_hypervisor (7.0 15107.796624)
com.parallels.kext.prl_hid_hook (7.0 15107.796624)
com.parallels.kext.prl_netbridge (7.0 15107.796624)
com.parallels.kext.prl_vnic (7.0 15107.796624)
com.github.osxfuse.filesystems.osxfusefs (2.3.8)

USB devices
Apple Inc.: Built-in iSight
Tablet: GD-0608-U
Apple Inc.: Bluetooth USB Host Controller
Apple, Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.16.77 310.40.00.20f04
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: Medium

@zervouli I’ll need to see more detail about your computer information to determine why Rhino is getting this wrong. You have Parallels installed, and that may be confusing Rhino. Please see this web page that describes how to collect and send a complete description of your computer.

Thanks marlin, I’ve attached the system report file. I hope that helps.
I do have Parallels installed but it isn’t active when I’m using Rhino -
the only Parallels-related process that is running is prl_naptd (as far as
I can tell) so it would be odd if Parallels somehow reserved video memory
with no active VMs, but I wouldn’t be surprised…

  • Claude

Sorry, but I don’t see any attached file. You might try emailing it to marlin@mcneel.com.

Got your system report. You have a Mac with two GPUs and you must log out and log back in to change which GPU you are using. Rhino was not detecting the GPU correctly with this Mac. I have a similar but not identical Mac for testing, and I could see a problem. This should be fixed in the next WIP release, but you’ll need to test this to make sure.

Hi Marlin, I have a non- retina macbook pro with 16GB RAM and 512MB GPU. However, there is absolutely no difference between the ‘none’ ‘2X’ and ‘4X’ antialias settings in rhino for mac (I have rhino v 5.0 Wenatchee 2014- 08-27). Is this a problem with my system, settings or will some level of antialiasing be implemented in the near future? Thanks

Please post your Rhino information from Rhinoceros > About Rhinoceros > More info…

Hi, My settigns are as follows;

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-08-27 (523)
OS X version: Version 10.9.3 (Build 13D65)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro8,2
Processor: Intel Core i7-2675QM CPU @ 2.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6750M 512 MB
Memory: 512 MB
Screen size: 1440 x 900
Displays: Color LCD

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Dell: Dell USB Optical Mouse
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.22.25
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: Medium

I am unable to duplicate this on similar hardware. I am running 10.9.5 and the 2014-09-17 WIP release. Rhino is not very reliable about instantly changing anti-aliasing on open models. If, after changing the anti-aliasing settings, you close all your models and reopen them, does the anti-aliasing change take effect?

Hi, Yes, indeed it does- thanks!
It’s difficult to notice, as the 4X option doesn’t not improve things drastically. Do you know if there are any plans to improve this in future versions or is it more a problem of my hardware/ GPU?
In the Windows version the ‘high’ setting is much, much better than the 4X setting in Rhino for Mac.

Anti-aliasing is limited to 4x on your hardware in Rhino for Mac. See this thread, especially my first post in the thread, for the anti-aliasing restrictions.

Hello,

on my MacBook Pro (Retina, 15-inch, Late 2013) Rhino 5.2.3 (5C258) Options / OpenGL does not show any antialiasing. Is that how it should be?

thanks and best regards

OS X El Capitan
10.11.6 (15G1004)

Hardware:
Processor: Intel Core i7
Processor Speed: 2 GHz
Cores: 4
RAM: 8 GB DDR3
Intel Iris Pro 1536 MB