Angle tolerance bug V5/WIP


#1

In the attached file, either use Wirecut to slice the “solid” part vertically (Direction=CPlaneNormal, through, keep the larger part), or just extrude the curve and use something like BooleanSplit.

Note that the cutting curve is actually a polyline, it has an included angle of a tiny bit more than 179 degrees. The resulting outer surface is just that - a single surface, where it should be a polysurface because the generating curve has a kink. The file angle tolerance is 0.1 degree, so this should split into a polysurface. But Rhino actually produces “dangerous” single surface geometry that is incorrect.

I’m assuming that the internal functions are using the ridiculously loose angle tolerance of 1 degree and not the user specified 0.1 degree tolerance for considering the surface created as a candidate for splitting. The proof is if you decrease the angle to just under 179 degrees (move the polyline endpoints about 0.05), the split surface is correctly created.

Please make the different operations involving surface creation such as Extrude and the like obey the user-set file angle tolerances instead of some made-up and too loose artificial angle tolerance (1 degree) setting as now.

wc.3dm (433.2 KB)

–Mitch


(Pascal Golay) #2

Hi Mitch - I see that, thanks.
https://mcneel.myjetbrains.com/youtrack/issue/RH-38321
-Pascal