Angle dimensions will not 3d scale with rest of objects and crazy lines in V5


#1

Hi,
problem with V4 and 5… latter also leaves behind planar surfaces !!!

In V4. I have selected origin of 3d scale, selected a start ref point, selected where I want that to end up, my objects scale, lovely :-).
.then I notice its not scaled the angle dimensions, they are still where they started.

I undo this and open that file into V5, try again.
This time not only does it fail to scale the angle dims, it also fails to scale the planar surfaces I had created through my points. This failure in V5 is a ‘no go’, at least I can redo all my angle dims again, but that isnt right !

What do I need to do, I have tried it both with all grouped and also ungrouped.

I then create a test file in V5, create the points and then PlaneThroughPt, add some angle dims, scale it 3D and the angles dont scale, but the surfaces do scale.

So then I create a test file in V4, is it V4 into V5 issue,…close V4 and open it in V5, scale it and angles dont scale but surfaces do. However the angles are now not just two arrow heads and a number with line between arrows, I have a line going all the way down from arrow head to some origin point at bottom of where item was and back up again !!! also remaining where the dims were. along with those dims.

In Properties it just says Dimension> default. what are these massive lines down to some origin and back up again ?
How does one get rid of them ? get one problem and find a second one !

I did see in the native V5 options of angle dimension. txt height 2.5, property> units mm, numbers are 25mm tall,
two and a half darker grided boxes, or 25 of the fine grid lines, and grid is fine line every 1mm.
what controls these lines that dont cross but go al the way down to where my two lines I have angle for meet ?

This test file attached.

Steve

TestScaleIssueAngleDims_PlanarSrf_V4intoV5.3dm (48.0 KB)


#2

Hi Steve, to scale angle dimensions in V5, you need to turn points on and select only a point which usually sits beside the dimension text. I suggest to try it out with an angular dimension between a larger angle to understand the logic.

To make the dimension text follow your edits after scaling, you could use the command _DimRecenterText. There is a button for it in the Drafting toolbar.

c.


#3

Hi Clement,
Does this mean select a dimension text then click on pointsOn icon, doing that I see a point appear between the two arrows, I then select the next dimension and do same and the first one still shows the point. If I have many angle dimensions I would need to select them all somehow, I often have a layer for all dimensions, however I also have them in other layers, so I would have to try and seek out each one and do this to all of them.

With this point showing between the arrows I then went ctrl A and selected all objects on the screen, used 3D scale and scaled my object smaller BUT the angle dimension actually grew taller, well at least this time they did move, but like a scene from jack and the beanstalk, the end result was my angle text sitting much higher than it was before with lines going all the way down to the object and back up.

Attached the two files before and after.

Is this right though , that angle dims wont scale like the dimension dims and diameter dims do ?

Are we stuck with this as such, I guess as we are at V5 and this also happens in V4 (apart from the long lines and growtall of V5) its something that cant be written out in the ‘engine’ and solved.
Just what are those massive long lines , when I create an angle dimension I get a line with two arrows and a number, I dont get lines all thw way down to where my two lines meet as is happening in V5.

I cannot go over to V5 until this is solved, I dont want those long lines.

Steve
TestScaleIssueAngleDims_PlanarSrf_V4intoV5beforeScale.3dm (43.9 KB) TestScaleIssueAngleDims_PlanarSrf_V4intoV5AfterScale.3dm (41.7 KB)


(Pascal Golay) #4

Hi Steve- you should be able to scale dimensions- we’re looking at why the ones in your file do not want to scale. I added my own and they scale fine. BTW, you will find your display performance much improved if you either shut off the grid (F7) or set the grid to a more reasonable number of lines.

-Pascal


(Pascal Golay) #5

Hi Steve- it looks like the scaling failure was caused by Rhino not checking diligently enough for the thing having been scaled previously- it looks like the dimensions had been scaled to .01 or so in past some time, and that caused problems with subsequent scaling. This will get fixed…

-Pascal


#6

Hi Pascal,
the file I placed in the thread was only one knocked up quickly to show what is happening to my ‘serious’ file.
so we have two serious files, the same file both in V4 and V5, not scaling angle dims, and this test mockup also not working.
if you found that the angle dims in this had been previously scaled to .01 such would not apply to the ‘serious’ file. Unless there is some sort of bug that is .01 scaling angle dims when they are made.

Try as I did making a fresh file with points and planeThroughPt and angle dims. Does it do these odd things to angle dims for you ? Note they didnt grow taller in my serious file, they just didnt move with the rest of the objects.

Is it necessary though to have to select them and turn on points, whilst for rest of dims that isnt necessary ?

I dont recall scaling my Photomodeler wireframe, of which you have a 3dm file. It was imported from Photomodeler, then rotated and aligned, but not scaled. The first scaling was carried out after I measured angle dims, and it left the angle dims where they were made !..but without those annoying long lines that you see in V5…what are they, part of the bug ?

Steve


(Wim Dekeyser) #7

I tried that before Pascal answered and wanted to reply that I didn’t see any problems with that. Then I tried your file and for a while tried to figure out what was going on with your dim as I, too, could make new DimAngles in that file and scale them without problems. Importing your dim in my template didn’t help either so I gave up on that.

Could you try just drawing 2 planar lines in one viewport and adding a DimAngle between those and then 3D scale these up? That should work without any problem, also without first turing on its points.

As for the lines protruding, they are just the “Extension line extensions” that are out of control. Turning on points on the dimension, you will (should) be able to move these). As your dimensions are not following the geometry, that won’t do much good, though… You’ll have to recreated those.