€ and ß problem in command line


#1

Hi,

I use rhino at work everyday and i use CTRL+ALT+E and CTRL+ALT+S key combinations often.

Problem is when i press CTRL+ALT+E to zoom extent in all viewports “€” symbol appears in command line and i have to erase or press ESC to write the next command or it says “unknown commad:…”. It is same when i press CTRL+ALT+S as well which switches to Shaded Display mode with the symbol of “ß”.

I am sure there is more of this kind of symbol appearances due to key combinations and it consumes modeling time.

My wish is a solution from the root of this problem.

Thank you

Rasim


#2

Sounds to me like you have some windows key-combinations enabled.

One solution is setting your keyboard language to “[your country] - US International”, same layout, but they don’t use the €/ß signs.

[edit]
I don’t know how to disable the hotkeys, but this at least should bypass it.


#3

Thanks for your answer,

As i learned from my search;
-windows hot keys are always windows key + D (for desktop) and so on. if it is CTRL, ALT or SHIFT then it is application related.

changing keyboard language to “my country US International” is no good for me because it is lack of characters for my language and also layout changes a little.


(Wim Dekeyser) #4

Just put " enter" behind the command string in the Rhino Options > Keyboard.


#5

Yes! that is it!

thank you Wim.