And another thing

Why do I always get such irritating artifacts after doing standard operations?? This image is from a surface blend operation using added shapes to the quadrants and making fine adjustments to a curvature rating. It seems no matter what, I get some jagged bullshit in the surface. (354.2 KB)

What specific commands/actions are you using and in what sequence?

The upper rim of the object is made lofting two copies of a curve.

This is to be booleaned into the main body later.

The next two horizontal curves are; a copy of the curve used in the upper rim, and a blended curve below it that was then pulled to an extrusion of the upper curve so as to make them align vertically. (This generates a large number of control points on arcing section of the curve. I used the remove multi knots tool to reduce them)

With these I used a 2 rail sweep to avoid a creating a polysurface. (Just because)

Next, having two surfaces to work with - The vertical face of the rim and the horizontal surface of the base, I use the blendsrf tool set to the curvature level and add shapes at the quadrants of the corner and another at the midpoint on the longer side.

Afterwards I use the remove multi knots on the surface.

Shown are the results with Zebra.

Later, after making a solid of the item, I get this anomoly in the originally acceptable surface.

How did you create the solid with the altered geometry? Join does not move control points to alter geometry. My understanding is CreateSolid only trims and joins surfaces but does not move control points to alter the shapes of surfaces.

I really don’t know how to explain these things. I sometimes suspect it’s a problem with the Z analysis. Here’s another transitional abortion using edge surf to complete a corner with different radius edges meeting

There are no options to choose using edge surf so it’s whatever happens.

It’s a polysurface formed so there’s no matching it to the simple lofted edges without exploding it.

Then trying to clean things up with the match surface tool is a joke.


It looks like the blended surface is performing as expected. I think you’ll always end up with a seam there based upon your input curves and surfaces continuity. One easy way to confirm this is by simply replacing your curves with G2 or higher and see what happens. I think you’ll find those seams will disappear.

On a related note the line work you’re using to create these surfaces is not precise and would cause anyone problems creating surfaces from those. I’d suggest backing up and concentrating on improving your line work and alignment skills, once you have that working better that will act as a proper foundation for surfacing the model. If the construction curves aren’t right your model is going to fall apart at some point, and that can be very frustrating.

Thanks for the criticism. I do appreciate it. I’ve reworked the item with a different approach. I think my line work is sound. I’ve two methods shown here. The first is a blend of surfaces. It’s showing some strange behaviour.

LineWork.3dm (2.5 MB)

The surface to the right is a loft while the other surface is an extrusion of a curve.

Next was a two rail sweep of the profile curves. After the surface is created, I hid the curves and extruded the surface edge. What I don’t get is why even when selecting the edge of a surface and extruding it, the zebra lines will not match up.


I don’t think that is abnormal behavior given how the surfaces you’re blending to are constructed, especially the extruded surface, Rhino is keeping that small connection tangent to the extrusion. I’m not sure why you’re attempting that sort of surface construction there for that top cap.

As far as sweep goes I don’t think there is an expectation of any sort of continuity above G0 being preserved so your sweep is acting properly, that’s why blend should be used if some higher continuity level is required.

Your first example at the beginning of the thread is not the same situation as the second, there are different factors at play.

On a side note for some reason your curves always show as racked and have seemingly random duplications when I load some of your files, that is the reason I mentioned you needing to brush up on your line work. There is a chance that my copy of Rhino is not reading your file correctly, however this misalignment and racking is present when I open the files in MoI as well.

I’ve been plagued with multiples for months. Seemingly out of nowhere I’ll click on a curve and there’ll be up to 15 duplicates! The curve hasn’t even been used for anything else. I did find some racking type problems and I’m becoming a bit depressed over it. It seems to me it shouldn’t be so difficult to create simple and sound lines.

BTW - what do you make of the behavior of the added shapes in the blend example?

BlendSrf matches with the specified level of continuity (G0, G1, G2, etc) the ends of isocurves which run across the blending surface with the corresponding isocurves of the surfaces to be matched. This is a method of achieving the specified level of continuity between the surfaces. Shape curves need to correspond to isocurves so they also need to satisfy the specified match between the ends of the shape curves and the corresponding isocurves on the surfaces to be matched.

So the behavior of the added shapes is due to the way BlendSrf works.

I kind of understand that. But as you can see, I’m only using a tangency parameter (G1?) on two simple surfaces. The surface to the left was made with an offset of the curve/edge that was then used for the blend. The surface to the right is an extrusion of the other curve/edge used in the blend. Is it the isocurves then that are causing the added shapes to deviate from the usual perpendicular orientation? I haven’t seen this before except in one case where the two surfaces edges were not properly matched.

Based on my experiments with your geometry it is the requested G1 continuity in BlendSrf between the blend surface, and the direction of the isocurves in your upper surface which is causing the shape of the shape curves.

I see! I suspected it was the resulting geometry from the offset curve causing the issue. Maybe it’s better to make a copy of the curve and place it a distance from the original and then loft., or maybe even just create a rectangular shape as it will ultimately be cut. I’m shaken none the less by my ongoing failure to create sound line work. But I aspire to a professional output, so another day and another bit of progress.



There is a reason I do what I can in MoI, I find I can accurately layout the model in that application and transfer into Rhino when needed. If you’re objective is for professional work I’d suggest broadening your search to evaluate tools that can fit in with an optimum workflow. There’s not a whole lot of reason to keep fighting a particular aspect of an application when there are alternate options available that will make your modeling easier that you can seamlessly transition between.