Ancient mesh bug in Rhino 7

From your gif, it places it on the layer the object is on, not the current layer.
your current layer in the gif is Default and the created object is the same as the original object, not the current “Default” layer

Several Rhino commands such as Rebuild give the user the option to place the results on the same layer as the input object or on the current layer. That is the behavior I prefer. For my workflows I usually need the results of Mesh or Quadmesh to be a different layer than the input object. The current always on the same layer behavior is annoying ot me. The addition of the option for the results to be on the current layer should satisfy both desires without “forcing behavior on customers”.


@theoutside , You have it backwards. Current layer means the currently active layer, not the layer the input object is on.

1 Like

ok, got it. thanks for clarifying.

I don’t question your certainty of what you believe that I believe. I have no interest in addressing this, or any other of your issues/concerns/beliefs. I was only addressing Kyle here on something that’s important in our design process.



Having the Mesh command, mesh to current layer would be super annoying to me. I often mesh objects on multiple layers and want the resulting mesh to end up separated the same way. I would have to run a script that mesh each layer and then change it back to that layer in order to have it behave the same way. Easier to just selLast ChangeToCurrentLayer if you want the new mesh all on the active layer

I believe that we need more opinions about this topic. Very few Rhino users have your preference - more users prefer placing new objects on the current layer. Probably the best solution is the one that Kyle posted in the myjetbrains: command option gives user the choice. I hope that it is “sticky” option.

I’d also vote for a command line sticky option like in Section command:
AssignLayersBy = CurrentLayer OR InputObject

that would work!