An issue on T-spline Smooth Mode


Can someone help me out with the issue I’m having with T spline smooth mode?

I’m using Rhino5 and Matrix combined on my desk top computer, and T-spline is installed into it.
I had no problem with T-spline objects until the day I found an error message. (Error message A)
After that, I started to see T-spline object in Smooth Mode is not smooth anymore. This object was created in the same computer without a problem. I didn’t finish making it the day before, so I open the file to continue working the next day then suddenly the object is kinky looking.

T-spline smooth mode should have soft curvature like the object when T-spline surface is converted into Polysurface. However, T-spline Smooth Mode objects are showing with edge as if the object were in Box Mode.

Here is how the object looks. (Tspline Smooth Mode -1)
On the right side, the objects are in T-spline Smooth Mode.
On the left side, the same objects are converted into Polysurface mode.
They both side of the objects should look the same with soft curvature.

I want to get T-spline Smooth Mode to show the object in normal soft curvature on my computer.
Has anyone experienced issue like this before? I’d appreciate if someone give me suggestions how to solve this issue.

Thanks in advance!

Additional note about attached images:
The attached 3dm file has the same object that shows issue on my computer. There was no problem with T-spline Smooth Mode on someone else’s computer, so it may not show the issue on your computer.
I attached two more images of kinky T-spline object in Smooth Mode. (Tspline Smooth Mode -2) (Tspline Smooth Mode -3) Both objects are the quadball simply created from the tool bar, so I have not changed the shape and it should look complete circle/sphere without edges on the surface.

Tspline Smooth Mode-2.3dm (3.6 MB)

I am not at home so I can’t verify for sure. But when you are have the Splines HUD up and have Tsplines shortcuts active there is 3 keyboard keys that change the visual appearance of your Tsplines model in Rhino. I believe the # 1 key (actual number key above Q) goes to low poly / blocky mode. 2 is a middle setting, and 3 is your normal fully smoothed model. I would try that and see if it helps.
They are sort of like mesh render settings in rhino. You can turn it down to get better performance on large assemblies that you want to have everything in smooth mode but don’t have a computer powerful enough to handle it.

Thanks for your quick reply. I made T-spline edit mode on and hit 3. The T-spline object changed to very smooth on the Smooth Mode!! Thank you very much for your advice!