AMD ProRender Rhino Beta Plugin...any info?

I tried the 17.3.3 and 17.2.1 drivers and still not working.

Could there be something else causing it to not initialize? an earlier version did work, before I did the uninstall prior to installing the new release.

Here is a link to the instructions I used to uninstall the earlier plugin (in case that could have messed something up):
https://wiki.mcneel.com/rhino/5/rhi/uninstall

Also sometime in the past when I installed an earlier version of the plugin, and it would not load, I checked the box to not load again. Could that cause and issue?

I have also tried installing the plugin for just me and for everyone with the same results.

Hi,

hard to say whats wrong. I’ve looked in the installer file to find out and double check what is installed on my system. I’ve installed this once only, using the “Just me” option btw. In the installer there are these files:

FireRender64.dll (2.538.496 bytes)
glew32.dll (370.176 bytes)
OpenImageIO.dll (7.660.032 bytes)
ProRender.rhp (168.448 bytes)

These have been installed in this location:

C:\Users\UserName\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ProRender (2aae3eb3-985b-4e64-b19a-fed69ef9dfeb)\2017.11.6.756

Check if you have them and check if the size matches. The RadeonProRenderRhinoPlugin_20171106.rhi file has a size of 3.176.189 Bytes. Could it be you have a bad download ? Did you unblock the rhi file before installing it ? (i did).

Btw. While searching for duplicates of these files on my system i’ve found there is a OpenImageIOv13.dll under C:\ProgramFiles\Rhino WIP. Not sure if that is required at all…

_
c.

Yes, they are both required, as they are different versions.

Hi clement:
Here is my install folder:

C:\Users\Mark\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ProRender (2aae3eb3-985b-4e64-b19a-fed69ef9dfeb)\2017.11.6.756

and here are a list of the files:

The file OpenImageIOv13.dll, is located in C:\Program Files\Rhino BETA\System on my system.
hmm… wonder if the beta makes a difference…

BETA
(6.0.17311.8431, 11/7/2017)
Beta

Not sure either. Mine is installed and located here: C:\ProgramFiles\Rhino WIP and i do not have a Rhino BETA under Program Files. Do you still have the folder for the WIP ?

_
c.

Nope, don’t have a WIP folder. I download the full install the other day to do a fresh install of the WIP. I didn’t realize it had been upgraded to a Beta when I downloaded it. When I uninstalled the WIP it must have removed that folder (unless I did it manually after uninstalling (don’t remember)).

It looks like the beta was released on the 7th:

@bisenberger, only a dev who wrote the integration can help you i guess. I have the Beta but it is installed in the Wip folder. My SystemInfo almost has the same for graphics as yours posted above. One difference is i’m on Win7x64 and it lists only 128Mb of Ram.

_
c.

@clement, I hope they come up with a solution soon. Windows 7 was one of the best releases, if not the best. Thanks for your help (again :grinning:).

I installed the HD7970 in a different computer running Work In Progress (6.0.17304.10081, 10/31/2017) Beta. I let Windows 10 Pro automatically install the AMD drivers. It installed Radeon Software Version 17.1.1. ProRender successfully installed on this setup, but keeps crashing.

The 7970 does date to 2011, does it actually support the right version of OpenCl to run ProRender? And if it did could you reasonably expect it to be useful?

The Rhino WIP installed the update to BETA (6.0.17311.8431, 11/7/2017) Beta and fixed much of the crashing.

Hi JimCarruthers,
Current OpenCL version installed 22.19.162.4. The ProRender in Blender works very good and I’m confident McNeel will get ProRender up to speed in Rhino. The OpenCL performance with Photoscan is also very good.

ProRender is pretty quick, but it does strange stuff to texture mapping and some textures. Here’s an image that shows the difference between how the texture mapping looks in a Rhino Rendered viewport compared to a ProRender viewport.

I can confirm this as mentioned above. Messing with the texture repeat values seems to set integers to floats and the default mapping looks wrong. I wonder if this has something to do with our display cards which are identical.

_
c.

@nathanletwory, @andy,

this is what i see when switching from Rendered Viewport to ProRender. It does not happen when i switch to Raytraced:

_
c.

what codec did you use? Firefox nightly doesn’t recognize.

Anyway, the effect looks like zfighting.

Hm, mp4 works over here when played with windows media player. (10 years old) but not in FF.

I’ve tried to upload the video now 4 times, *.avi is not accepted, *.mp4 (converted from avi using h264 and VLC cannot be played, when i zip the *.mp4, filesize 5Mb and drag it over the message window it shows the upload progress till 99% then nothing.)

ProRender.zip (5.2 MB)

Images, first is Rendered viewport, second is ProRender using the same view:

image
image

Imho, z-fighting looks different.
_
c.

The mapping is indeed also wrong. I meant the circles shining through the plane when you rotate, at least towards the end.

Yes, the circles have been caused by the groundplane. Good you’re now seeing that textures don’t work. I’ve found more bugs in ProRender importing larger files without using any textures. It seems all my geometry looks like having triangular faceting effect in variing grayscales which occassionally vanishes if i zoom very close to the object.

_
c.

The dev working on the ProRender integration (not me) is aware of the mapping problems. I’ll let him also know about the meshing.

You can btw also report bugs on the github repository AFAIK. That would probably useful (:

Thanks for all the feedback. I am currently working on building ProRender with the latest toolkit. After that I will look into your bug reports and wishes.

1 Like