Alt + copy seems to be broken

i do, but sure not with alternative osnaps.

I got the feeling this topic was not started about alternative osnaps… It was started about tapping Alt not consistently engaging the copy function. I explained why this might be buggy.

–Mitch

the actual topic is about grasshopper, just to point that out once more. you explained why rhino alt copy is supposed to be buggy which it is not, it simply is not handled or lets say thought through and executed properly in the software.

we can open a new thread if you insist but the topic name is as misguiding as it seems sure also usable to discuss the rhino alt copy issue i hope.

hmm. single tap works fine for me.

fwiw, there’s another pre-click function tied to alt… that being, you can hold down alt while the cursor is over an object then do a window select without dragging the object.

also, it’s used for zoom (to center) in conjunction with right-mouse-button.

lots of stuff on alt/option key… arguably, too much stuff but maybe a little late to be switching it all around now.


re: grasshopper.
again, alt/copy works ok for me… with one component or multiple components.

1 Like

yup, i didnt realize that it actually works only on release, tapping is obviously something different to pressing so most probably my bad :blush: but also holding it longer and letting go does not work reliable which lead me to believe i have to press twice. in grasshopper it works already on click, rhino could at least work the same here. any other software i know of including the macos finder lets one duplicate the object pressing alt before or after the dragging process has started.

i believe thats cmd + RMB

yeah, for mac users, the behavior in Rhino regarding alt is weird…
i think i remember a discussion about this a few years ago but i’ve since gotten used to it.

command+RMB will zoom to cursor… alt+RMB will zoom to center (generically(?) zoom the viewport regardless of where the cursor is)

well i hope that dan or anybody might have a look into this thread considering to issue a clean up.

ah yes i didnt notice, i tried in the orthogonal projections where it didnt work not sure where to use that though?

i don’t use it and also am not sure of a situation where i’d need that type of zoom instead of zooming to cursor…
anybody?

I think this behavior is a bit weird too. However, I’ve gotten used to it (but I don’t do a ton of modeling any more). For me, this is one of those “Well, Rhino for Windows and Rhino for Mac are a bit weird, but consistently weird” issues.

in grasshopper it works already on click, rhino could at least work the same here.

I’m not certain what “on click” means here. In Grasshopper, I always have to be careful not to hold alt first before I click the component, otherwise I’ll trigger the “Moses” separation functionality.

-Dan

1 Like

i meant that it works while already pushing the alt button in, contrary to rhino itself where the button has to be released completely and very fast, to trigger the plus to show.

:crazy_face:

1 Like

hey jeff i tried to find out what this alt RMB is all about and searched but could not find this specific combination explained on the wiki. but i figured that it actually always zooms towards the camera target which one can change with MoveTargetToObjects keeping the targeted object always in center, still no idea where this could be useful but maybe for keeping a specific perspective in the same tangent for architectural reasons… idk

edit: wel it seems that it not only zooms towards the target but that it actually moves the target, the same as using alt and mouse wheel. useful for extendedly moving along in the viewport… ok riddle solved i guess :slight_smile:

Alt+RMB click and drag is a “Dolly Zoom” that leaves the camera frustum the same size, and moves the entire frustum forward.

Draw a box in a new file
While Perspective is current, run Camera > Show to see the Perspective VP frustum in the other three viewports.
In perspective, use the mouse wheel to Zoom and you’ll see the camera point move towards the stationary view target.
Now try Alt+RMB wheel Zoom to watch the whole view frustum dolly forward.

yes i have figured that, i wrongly declared zoom above, i meant that it is only moving, something which might be handy to have as standard on the mousewheel without alt because the regular zoom naturally finds an end which is bothersome for navigating. but what an akward word frustum where did you dig this out? sorry really never heard of it, i can see though that it is “commonly” used…

Frustum is just the geometric name of what you’re describing.
Did your run the Camera command and see what I’m talking about?
The whole reason for “Dolly Zoom” (Alt+Zoom) is to easily push the view target ahead when in a Perspective projection view to not “get stuck”.

i made a thread about this reason as you stated to ask how to proceed when getting stuck a while ago. thats why it really would be nice to have this as a standard option for the mousewheel. not sure if zoom makes sense at all for navigational matters… i would rather have zoom on the alt.

It is how the standard wheel Zoom works in a parallel projection viewport like top, front, and right.
In a perspective projection view you need to press and hold Alt (Fn+Alt) on a laptop to zoom the same way.

TUrn off the camera in the Perspective VP and turn it on in Top or Front.
Then try it again and you’ll see it does what I’m describing.

hmm i think thats not true, i checked now and in all orthogonal viewports its not moving the frustum but it actually zooms. moving the target is only possible in perspective as it seems.

Hmm…
I’ll need to go look at that again.
I only ever use the Dolly Zoom in a perspective projection viewport anyway.

thanks guys, this is a very informative thread.

I’m using a mac keyboard on windows and that works for me. Thanks