All layers on when opening a rhino file


#1

Hi,

Whenever I open a Rhino file, either my own or from someone else, all the layers default on. I thought this was standard to loose the layer states, but have recently found out this is not the case.

I have searched and cannot find anyone else with this issue, is there a tick box I’m missing somewhere? Does anyone else have this issue?

Ignorance was bliss, but I could save a lot of time by solving this.

Thanks in advance,

Paul.


Clayoo messes up my layer manager
#2

Would you have anything in your startup commands like the command AllLayersOn - or a startup script that does the same?
– Mitch


#3

Thank you Mitch,

I will have on my machine when I get home. I can find the startup script, but where can I find and edit the startup commands?

Cheers,
Paul.


#4

I have this same problem except that it pertains to worksessions and layout views. When I open a worksession, my detail views in paperspace (existing in the active file) automatically show all layers in the detail.


(Wim Dekeyser) #5

Startup commands are at Rhino Options > General > Command Lists > Run these commands every time Rhino starts.


#6

I seem to recall someone else posting something similar awhile back - unless I was dreaming… --Mitch


#7

Thank you for the help.

All I have in the script is a pascal clipping plane curves add on and nothing in start up commands. Any other ideas?

Thanks,
Paul.


(Wim Dekeyser) #8

Not really. Would you mind posting the command history of the sequence of launching Rhino and opening a file that was saved with layers turned off? Maybe that sheds more light on this one…


#9

Loading Bongo 2.0 Nov 14 2014 04:06:13
Welcome to Clayoo 2.0.0.7!
Loading V-Ray for Rhino, version 2.00.26563
Loading Autodesk T-Splines Plug-in for Rhino (Version: 4.0 r11183 (64))
Loading Flamingo nXt 5.0 5.0.16179.14183 built 6/27/2016 10:19:49 PM
Loading Rhino Render, version 1.50, May 23 2016, 15:18:38
File “C:\Users\Paul\AppData\Roaming\TDM Solutions\Clayoo\2.0\Resources\Toolbar\Clayoo.rui” is already open.

Plug-in central. Definitely was not happening before Vray and Tsplines, I’m looking at Bongo or Flamingo as the suspect. Im going to look into seeing how to load rhino without the plugins and I will let you know what I find.

Cheers,
Paul.


#10

We have a winner!

All the plugins above were fine. It turned out to be a trial version of Clayoo that was installed. Once that was off, problem solved. My Rhino now opens much faster with the plugins now turned off for general modelling.

Thank you for all the replies, 2 birds with one stone here!

Cheers,
Paul