Align objects in a grid

Hi everyone! I’m trying to move parts of a little building I made onto a grid. For some reason it just copies one object a bunch of times (22 times) in the x-axis and only the y axis changes object. For example I only have one door frame but here it seems like I have 22 of them. Anyone know how to fix this?


There is no file to work off of. But I think that you need to graft the geometry component output.

It sounds like you’re experiencing an issue with Grasshopper where your building components are not being distributed as you intended. The problem you’re describing could be due to a variety of factors. I would try like Ryan said to graft the geometry. If this is not working try to flatten your geometry list.

Ah, sorry here it is:
I tried grafting the geometry but this just changes the direction, now y keeps the same object and x changes.
Whole system.gh (18.4 KB)
whole system.rar (1.9 MB)
.

Thank you! I actually tried both and they didn’t seem to work, in a post below I also added the grashopper script and the rhino file if you would want to take a closer look.

@Elisa_van_Klink_van
Whole system RWG.gh (11.9 KB)



image

Awsome thank you!

1 Like