Airtable to Grasshopper using Mallard

use the directions in this link, and once you submit the pull request, i’ll go in and review it and hopefully approve it! :raised_hands:

let me know if you need help with any of these steps! github can be quite confusing

Hi Nick,

I did the pull requests, please check.
Thank you.


i just merged your edits, and credited you! congrats!


Great, thank you!

How to use Mallard, for connecting grasshopper to airtable, in 10 min:


Hi @Nick,

I was trying to have Mallard upload attachments to Airtable, and I failed at the first time. So I did some study on Airtable API documentation and Airtable.NET source code, finally I updated Create/Update components to have the feature upload attachments worked.

So, about the update, it was based on following references:

  1. To create new attachments in attachment fields, from Airtable API documentation

  2. Error message

  3. Source code of AirtableRecords.cs from Airtable.NET

Finally I modified this part:

Below is a sample that used Mallard to create records with multipel fields, different field types including string and attachment, to Airtable. In this sample, plugin jSwan was used to create attachment objects from urls.

You may want to take a look of this, I had made a pull request on GitHub.

Wow :star_struck:

You’re incredible!

I was trying to figure this out but haven’t had the time! Thank you so much.


1 Like

Would love to use the plugin in Rhino for Mac too!
Would you by any change look into this? :slight_smile:

Thank you!

Hello Nick! I am really grateful for your plug-in. but I have a problem with the fields component, I have this message and I don’t know why… I have double-checked the table on airtable, please can you help???

I am trying Update Airtable Record component, but it does not work well.
Can you give me a sample file of this component?

It looks like you need to provide the Airtable Record you are looking to update as the input to the “R” field. This means you need to provide the Record itself. Do not convert it to string or text.

I hope this explanation makes sense.

I would upload a sample file but it wouldn’t work without a base ID and an app Key

1 Like

Thanks for the reply.
I was able to solve about it.
However, when I update Airtable with Update or Replace, the data is duplicated.
What should I do about this?

thanks (9.1 KB)

1 Like

I just tried it myself, and it wouldn’t update. something is definitely messed up with the component itself. it’s not your fault.

I may not have time this week to get around to fixing it but I will try.

Here is the github repo for the project if you want to try digging into the code yourself. please let everyone know here on the forum if you manage to improve the plugin in anyway.


Any change that this is already solved? :slight_smile: I have duplication problems as well. I would really like to use your plugin.
Thank you

Hi all,

Just updated the List component to be able to pull more than 100 records from a table.

Thanks for everyone’s support!

Major update for Mallard to 2.0!

  • duplication issues resolved
  • async update allows script to be used while mallard fetches new data
  • fields issues have been resolved
  • clearer instruction demo file with a sample database
  • icons redrawn to be more readable
  • plugin simplified to just 5 components

Get Mallard 2.0 here:

I try to create a layers from airtable using Elefront Bake Layers but there is some problem (two plugins are getting confused at load time?). Do you have any idea how to fix this?

and is it possible somehow to auto update List component for example?