After importing mesh from STL I can't input numerical values with decimal

Hello to everyone.
I’ve been rhino user for 7 years.
I’ve been dealing with this issue for last days.
Only after importing a mesh from STL (not copy/paste from another file) the command line begin to show decimal numbers with comma instead of dot as usual; it doesn’t accept decimal part of a number (written either with comma or dot) and takes only the integer part of it.
I use rhino 5 SR9 64 with Win 8 64.

Same actions with same files works fine on another pc win 7 64
Same issue with old files that worked fine in the past

Removed rhino 5 (but not rhino4 update neither rhino 3)
Tried with rhino 5 SR0
Removed NVIDIA driver
Removed all recently installed software
Antivirus and antimalware scans done

The problem still remains

Kindly asking for urge help.

Thank you

This sounds very very similar to problem users of ours were having but just with Rhino 5 32 bit that haven’t seen on the 64 bit…See if this reproduces it…simply have Rhino open on system that is exhibiting this problem then do file, open and after picking the file see if problem is there, if not repeat with file, save, file, import, file, save as…in our trials with this it had something to do with file dialog or 3rd party shell extension, I don’t know if we and or McNeel ever totally figured it out. Like I said eventually all moved to 64 bit so went away but symptoms are EXACTLY same.

Thank you for prompt reply.

I’ve tried as you said but the problem remains: from the moment I import or open a STL file (or a rhino file including a mesh) the only thing I can do is to quit rhino.

If I open the file by double -click on it the issue doesn’t occur (either STL or 3DM file).

It only occurs on “open” and “import” and it seems similar to the problem you remember for rhino 5 32 bit.

The thing I find strange is that I’ve been using this pc for more than a year with rhino 5: what did it happen last week?

Like said, not sure if ever found exact solution. we were lucky that at that time almost all our users could simply start exclusively using 64 bit Rhino and this went away. (and I will say this happened to only handful of users of ours) I think last thing McNeel and we were looking at was explorer shell extensions possibly (i.e. dll to help view files in explorer, or add menu capability via explorer to different file types). I think quick fix was McNeel had a command that would allow using ‘old style’ explorer dialogs and that also solved problem (though I think you lose thumbnail previews when doing this in the dialogs)…wish I remember that command for you but I’m sure someone from McNeel will know what I’m talking about…

Hi Maurizio - the problem apparently comes from Windows shell extensions (if this is the same problem as the one I know about) - the one we’ve been able to identify here is iCloud for Windows, but there may be others. SR10 of Rhino should handle this better- the release candidate is available, you can get this if you set your Rhino Oprtions > Updates and Statistics to look for Service Release Candtidate updates.


I installed SR10 but the problem is still there.
I have recently installed iCloud but unluckly its files are corrupted (perhaps it’s the origin of the issue?) and I can’t remove neither repair it or reinstall: I tried Ccleaner, Revo Uninstaller and IObit Uninstaller, but no way to remove iCloud for Windows.

Maurizio, can you please try the test command


Like all test commands,it will not autocomplete

What result does that give, if any? (I’m not sure it got into the public build yet)

@dalelear, I’m not sure if the fix for this got into RC1 of SR10… should it be working better now for Maurizio?




When I run this command things come back to normal.

It says: “Decimal point printing and scanning was repaired and is working now.”

Put it in a button and ready to push it after every mesh import.

Any chance of solving the issue in final SR10?

Thank you so much: I manage mesh every day and this problem caused to me a great waste of time.

Moreover I’m a Rhino ATC and it’d have been quite embarassing having such an event happening during a course without any idea about it.

Thanks a lot to ChrisIARhino as well.

Have a nice day.


Maurizio - I think running the command should fix it, period, for that installation of Rhino- do you find you need to run the command repeatedly?


Yes, I do. Every single time I import or open a mesh, the problem comes again duly. I push the button and it clears, but no permanent solution here. I hope for it, anyway can go on with my work.

OK, thanks, let me see what I can find out about that.


Hi Maurizio- it looks like you need to sign out of your Apple account/iCloud in order to be able to uninstall it.


Sure, but being files corrupted I wasn’t even able to open it.
Eventually I managed it by several uninstaller and register cleaner

Hi Maurizio,

Does this problem happen if you open a 3DM file? Or only if you open an STL file?

Hi Brian, now that I removed ALL iCloud files it seems that all is ok. I can import and open mesh from 3DM and STL. The problem happened with both STL and 3DM files (3DM only if containing a mesh); the only chance I had was transferring the mesh by copy/paste to another empty rhino file.
I had to use different removal software and repeat several times a registry repair: there were lot of iCloud pieces in the registry.

Same prolbem here, could no longer type any number behind the decimal point… till i uninstalled iCloud!
Man i found this blog only after i went through several other trys including install/uninstall cleaning user profile, etc.

Thanks for the iCloud hint!

Im not actively using iCloud but i wonder if there is a solution for people who use it.

Cheers Christoph


In the last days the problem happened again.
Anyway I solved it easily by the command TestDecimalPointPrintingAndScanning.

But yesterday I updated with official SR10 and this command has desappeared!!!

Now I’m blocked with the issue and the solution is not more available!

Please help me!

Can I return back to SR9?

OR (better)

Can I have back again the TestDecimalPointPrintingAndScanning command ?

Thank you in advance


For guys like me with hidden pieces of iCloud still remaining in the registry and impossible to find out even usin several third-part uninstaller:

To total uninstall of iCloud it was useful this Microsoft utility:

answers from Microsoft Community

After done that, I INSTALL , log out iCloud and UNINSTALL iCloud for Windows

Now the problem “seems” solved, at least I hope so.

Hi Maurizio - the developer changed the name - TestDecimal now…


Hi Pascal, thank you but I get “unknown command” (even with underscore ahead of it)
Anyway I hope to have got rid of it now…