Advanced Texture Preview

Hi @stevebaer, @jeff,

I have a single nurbs surface which uses a custom mapping object (mesh). The RenderMesh of the surface was extracted and unwrapped in another sofware, then re-imported into Rhino so i can use it to have better UV-Mapping.

If i assign a texture to my surface, it looks extremely blurry (in RH5 and RH6). The same texture assigned to the mesh looks very crisp. I’ve found that the reason for the blur is the “Advanced Texture Preview” option in the Rendered Displaymode. If i turn this OFF in RH5, the texture looks crisp on the surface and identical as when applied to the mesh.

If i turn OFF “Advanced Texture Preview” in RH6 it also removes the blur, but the custom mapping link is lost and cannot be restored by using the _ApplyCustomMapping command again. Somehow, i can only return to that custom mapping state if i use the _UVEditor command once. (I just make the rectangle and click OK and all is well).

Is there a reason why “Advanced Texture Preview” is ON by default ?
Can i turn it OFF via a command or code ?


Hi @clement, Sorry, I don’t have a clear reason why this is happening at the moment (mainly because I don’t work on the ATP stuff)… I think @andy and/or @Jussi_Aaltonen will be better at addressing this one. It’s possible the display pipeline is doing something wrong here, but I’ll let @andy/@Jussi_Aaltonen make that determination once they look at this.


@jeff, thanks for your reply. My images are 2K, 4K or 8K with transparency. Maybe this has something to do with the pixelated look using ATP. I get the same effect when i use procedurals (the texture in the display is build up step by step once applied but it never reaches the sharpness or resolution of the original). When applied to a mesh, it does not do this.

Hi @clement, Yes, one cause of blurriness is the limited resolution of ATP compared to your texture images. Sometimes objects with custom mesh mapping preview fine without ATP but generally this isn’t the case (for example mapping meshes with texture discontinuities). Therefore it is enabled by default.
There’s EnableAdvancedTexturePreview in ON_ObjectRenderingAttributes to control it through C++ SDK.

This sounds like a bug but I can’t repeat it. Could you send me your model so I could investigate?

Hi Jussi, the files are too large to upload here. I’ve tried mcneel upload as well but it did not work. I will send you a link via PM.