Advanced GPU lighting in Rendered viewport problem


I have a problem with the Rendered viewport and I think it belongs to GPU. In this one interior 3D file I am working on, most edges look like the Antialiasing is disabled. If I turn the Advanced GPU lighting in Rendered preview off some edges look smoother, but other more pixelated.

I made some screenshots for better understanding of this problem:

First edge with GPU lighting on/off

Second edge with GPU lighting on/off (same viewport, angle etc.)

System information:
Version 5 SR12 64-bit
(5.12.50810.13095, 10.08.2015)
Antialiasing in on x8

I also opened the file on Rhino WIP but the same problem occures.

Has anyone an idea how to solve this problem?
Thanks for your help :slight_smile:

Greetings, Simeon

Hi Simeon, my guess of the moment is the difference is due to the different background colors in the two cases.


Hi Pascal,

to the different background colors? Both cases are just details from the same view. So you can see both edges the same time and one of it has always a bad quality. With turning GPU lighting on/off the quality of the one gets better, but the other one gets worse.

I compared this case to other Rhino models and realized that all outlines get more pixelated in Advanced GPU lighting mode. It looks like Rhino is setting the Antialiasing lower by activating GPU lighting.

I also tested this on 4 other PCs but the problem still remains.

Any other ideas how to solve it?

Hi Simeon- I was just noticing that ‘First edge’ and 'Second edge’in your images are seen against light and dark backgrounds, and this might account for the second one looking cleaner in Advanced GPU mode.
As far as I know there is no adjustment that you can make in Rhino to change this other than the level of anti-aliasing, though there may be settings in the video card controls that affect this.


Ah okay now it’s clear for me what background you ment.
You know any settings that can be done by video card driver, that influence Rhino in a positive way?