Adjustable curve blend problem


#1

Using ‘adjustable curve blend’ on the Mac is behaving differently than in the Windows version. In Mac Rhino you have to click twice on the second crv. Once should be enough.
(And spacebar as enter doesn’t work).

Philip


#2

Hi Philip.
It works fine here. A single click. (WIP 5E63w)


#3

Hi Simon

‘Adjustable curve blend’ has never worked for me on my Mac - without the second click on the second curve. ‘Blend curves’ does work as it should. I wonder what’s wrong with my Mac Rhino…

Philip


#4

works here too, maybe something is messed up with your rhino. reinstall maybe?

but space does not work i can confirm that, hitting enter is the only way to proceed unfortunately.
i believe its not the only command which proceeds with enter only… instead of space either.


#5

Hi Philip
Out of curiosity, you can try to select the curves with square selection from left to right?


#6

I’m not at my Mac right now, so I can’t check (only Windows here at my day job) - but I guess that should work…
If you guys don’t have the same problem I really wonder what it might be… I have had this problem as long as I can remember - in the WIP versions (haven’t checked the official release for a long time - I could try that, when I get home).

Philip


#7

Ok, back home and in front of my Mac. Now I found the problem. I have “show curvature graph” on. When the curvature graph dialog box comes up it ‘steals’ the focus and I have to click once to get the focus back - and the second click for selecting the second crv. Disable showing curvature graph and it works as it should.
Could we have a fix for this @dan and @marlin… and a fix for the spacebar-as-enter problem?
Thanks!

Philip


#8

@dan: did you see this?

Philip


(Pascal Golay) #9

Hi Philip - thanks, I see this.

https://mcneel.myjetbrains.com/youtrack/issue/MR-3091

-Pascal


#10

Thanks Pascal!

Philip