Add Linear Dimesion error

When I try to use Add Linear Dimesion component it gives me this error:

  1. RhinoInside.Revit.GH: The direction of dimension is invalid.

Am I doing something wrong?

Hi Gurkan,

Can you provide more information? What is the orientation to the Revit View? Thanks

I tried it on Site view.

I am currently on revit 22 and latest daily build of rhino inside. on RH 7

Can you provide a small example your conditions? Revit is fairly particular on what it can dimension to in a view.

Thanks

Hi @Japhy. I’m facing similar issue with Add Linear Dimension component.
I’m using Revit 2023>Rhino7>RhinoInside v1.18
Image1: Tried referencing Revit native geometry for the


Image 2 : component exception + Error message in linear dimension component as- 1. Object reference not set to an instance of an object.

Image 3: Alternatively tried giving detail line created in revit first to feed as reference for linear dimension. Still gives me same errors as mentioned above.

Let me know if you suggest any other way.
Thanks :slight_smile:

Same as above, we’ll need more info to be able to help

My problem was not projecting line to flatten it btw. Sorry for not updating :slight_smile:

1 Like