Add License

I can’t add a license
image

…because I can’t select a product type.
The combobox is empty.

I ran the diagnostics tool - all fine.

What can be the cause?

@pascal
Really no idea?

That’s weird. I’ve never seen that before. Can you please repair your installation of the Zoo and see if it fixes the problem?

It doesn’t.
Also uninstall/install didn’t change anything.

We’ve logged that bug here:
https://mcneel.myjetbrains.com/youtrack/issue/ZO-209

It appears that connecting the Zoo to the internet makes the license types appear.

@Brian

But in here, the Zoo is on a real machine, and not in a VM.
And this real machine is always connected to the internet.

What version of the Zoo do you have? If you are at 6.4, please uninstall it and reinstall 6.2 from https://www.rhino3d.com/download/zoo/6/latest

Hi @Charles,

Before following Brian’s downgraded instructions, try stopping and restarting the service. Does this help?

– Dale

I’m on 6.2:
image

Tried that already.

No.

So far we are not able to duplicate what you’re seeing.
I can duplicate it on a VM with no Internet connection, but so far, that’s it.
We’re still digging.

Can you describe the system?
Is it waiting to reboot after a Windows update?

I can offer a TeamViewer session, if that helps.

A regular PC running Win10/64, latest incarnation, up to date.

No.
Nothing like that.


Rhino 6 SR3 2018-3-19 (Rhino 6, 6.3.18078.21401, Git hash:master @ 0712302a52476cbd0494d6f3b7d314c279bf19ae)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GTX 1060 6GB/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.71)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-15-2017
Driver Version: 23.21.13.8871
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

All that looks fine.
A teamviewer session is of no use, but thanks. We know what the problem looks like.
We can duplicate it under specific conditions but not so far on a system setup like yours.

Thanks

@Charles, if I understand correctly, you’ve installed the Zoo on the same system that you are using Rhino?

Correct.
I don’t intend to use the Zoo for the license management (not possible anyway for Reseller licenses).

I want to see how it works for customers, because we have questions around the Zoo.

So I don’t need the Zoo on this machine, just wanted to point out an error.

@Charles
Please download the current Zoo 6 SR4. It was posted just a could days ago.
We think we have this fixed.
The only time it doesn’t display license types is when Windows tells the Zoo service there are no Network Interface Cards (NIC) so if the machine is isolated and not on a network at all.

Any luck?

Unfortunately, no.
Same as before.
image

With this (new) Zoo:
image

After start:
image

When trying to add a license:
image


What is wrong, what to check, and how to fix it?

Thank you
Charles

Nudge…

Regarding the service:


Yes, it runs.

What to do?
Charles

No comment?
Hmm.