Add Chinese text solid objects


#1

I am trying to create text solids using simplified Chinese characters. I can type the characters into the Text Object Editor just fine, but when I go to select the area to create the object I get the following error:

“Could not create any surfaces”

Is this a general limitation, or a bug. Is there a workaround anyone might be able to suggest?

The text I am trying to write in Rhino is “十二” without the quotation marks.


#2

Can you create them as curves first? That would allow you to check what the curves look like and see if any are open/bad, which might be preventing Rhino from extruding.

–Mitch


#3

I tried that too yesterday, but even curves failed.

Oddly, today it just worked (albeit the text is added in a top-to-bottom direction and is 90 degrees CCW rotated). Must have been a bug?


#4

To further Mitch’s suggestion, a “What” command on a text curve can report a perfectly “valid (closed) curve” but I’ve come across my share of TrueType curves that exhibited problem spots that would result in bad solid extrusions. They often occur where the curves make a sharp kink. Often so small, it’s only visible with a lot of zooming & inspecting. Here’s an exaggerated example:

As for the sideways Chinese text, I’d certainly classify that as a bug. Possibly the Text Object dialog box is taking hinting code from the font? I’d guess that some of the Asian Unicode characters contain hinting that they’re sometimes laid out vertically and Rhino is improperly using this? When the text is pasted into Notepad.exe from Windows Clipboard, it’s oriented correctly and entered in a valid left-to-right fashion. Heck, even pasting clipboard contents into Rhino’s Notes window behaves properly like Notepad.

Just checked… looks like a bug with Chinese and Japanese characters. Korean pastes in the proper direction.


#5

I contacted Tech Support about this. They said that using any font with the “@” symbol in front of it when writing in Chinese will make the text behave this way. I tried “FanSong” and “Kaiti” without the “@” and they both worked fine.