AA problems in V6 on one computer only

unhandled

#1

I have one computer here with V6 installed that won’t support AA at all. If I turn on 2X, 4X or 8X, there is no difference, except that the selection window disappears. If I turn AA off, the selection window is visible again. I loaded the latest drivers, but Rhino can’t see the driver version or date. It works fine in V5.

Here is the system info:

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro M2000/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 377.83)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Rhinoceros 6.0\Plug-ins\AV Plug-ins\AVCommands.rhp “AVCommands”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Thanks,

Dan


#2

Anyone else see this?


(Jeff Lasor) #4

Sorry Dan, at the moment I’m not seeing this, nor have I seen anything like this come across my desk. I have seen the N/A’s for driver date and version, and that’s an issue that seems to be forever plaguing that OpenGL screen. However, it doesn’t really mean anything…as those two values are found by digging around a chain of chained Registry keys…and for some reason, it’s extremely inconsistent from system to system.

That being said, the rest of the information is actually gotten by direct queries to the driver…and it looks like that is all working and correct… You have a Quadro M2000, with 4GB of memory, running OpenGL 4.5… And I can actually see the driver version in the Adapter string (377.83)… So everything looks good from a driver/adapter/usage point of view.

The first thing I would try is unchecking the “GPU tessellation” box, just to see if it’s the cause of the disappearing selection window.

The next thing to check is whether or not your NVidia Control Panel has AA turned off globally, or if there is a V6 profile setup, look to see if it’s got any kind of hardwired AA setting… it should be set to “Application controlled”.

Also, see if this is consistent across all your display modes… And determine if it’s only the wires/lines that are not getting AA’d, or if it’s everything (i.e. look along shaded mesh silhouette boundaries and see if it’s being AA’d with the background, or whatever else is behind it).

I think I might have a Quadro M2000 here, so I’ll take a look to see if I’m seeing the same thing…but to clarify…this isn’t a laptop, correct? It’s not a Quadro 2000 M in other words… it’s a Quadro M2000 workstation card? Gotta love their naming conventions :slight_smile:

Thanks,
-Jeff


#5

Hi Jeff,

Yes, this is a desktop computer. For what it’s worth, we probably have 30 of these cards and this is the only one misbehaving. I’ll follow up on all your suggestions in the morning.

Thanks,

Dan


(David Eränen) #6

Hi @DanBayn,

Is it so that that’s the only computer in your office which has N/A in the driver date field?

If that’s the case, I would strongly suggest you uninstall all your NVIDIA drivers (using Windows’ “Add or remove programs”. Then when you re-install the driver you should check the [x] clean installation checkbox. Reboot Windows and start Rhino again. Better?

-David


#7

Hi @jeff, @DavidEranen,

Here is what I found out:

Unchecking GPU tessellation did not make any difference.

AA is set in the graphics settings as application controlled, but many of those settings are “grayed out” and can’t be changed. Fortunately it’s set to where you suggested.

This behaviour was visible across all of the display modes, even wireframe. It looked to me like it’s only the edges and wires that are affected.

David, I followed your advice and stripped all of the old drivers out, and reinstalled the latest. It’s still reporting as N/A for the version and date, and set to dynamic streaming, most of the options are still unavailable, but Rhino looks pretty good. The issues seem to be gone. I’m going to have the user stick with V6 all day and report back if the issues seem permanently solved.

I will let you know.

Thanks,

Dan