AA cannot be turned off fully

Hello everyone,

I see a similar display problem on Rhino 8 for curves in wireframe mode as well.

For years on Autocad and Rhino 7, I haven’t used antialiasing because it makes it easy to see if a curve isn’t perfectly horizontal, thanks to the staircase shape it displays.

However, I bought Rhino 8 today, and I notice that the display of curves is much less well represented than on Rhino 7. It’s as if the curve changes thickness with each step.

It’s really not visually pleasing. The curve seems to make waves or a twist.

Rhino 7 :

Rhino 8 :

@Matthieu_SAMSON can you try

_TestWireThicknessScale at different values to see if that makes curve display any better at your end? Here on a 4K display 1.4 seems to improve things against a gray background and with AA turned off, against black

Edit: I now see what you mean, this is a different issue.
RH-79022 AA cannot be turned off fully

Ok. So is this being fixed? The link to the issue sending to a 404 error

You can now see the link

Thanks @Gijs

RH-79022 is fixed in Rhino 8 Service Release 5 Release Candidate

My version 8 is up to date, and this problem still persists from my end

image

Your is still version Rhino 8.4. The fix is applied for Rhino 8.5.

Your Rhino will state this unless you change your update type:

image

Dear Mr. Brian Gillespie,

Could you provide me with some information about the release date of Rhino version (8.6.24074), please?

We release Service Releases on the second Tuesday of each month, unless there’s something that prevents us from shipping. So 8.6 is scheduled for release April 9, 2024.

Rhino 8.5.24074 was released on the 74th day of 2024 (March 12, 2024).

Dear Mr. Brian
I hope the next update can help me fix the wiring issue, but its curve resembles a sawtooth pattern, whereas previously in Rhino 5 and 6, this line was straight. My current computer configuration
Rhino 8 SR5 2024-2-27 (Rhino 8, 8.5.24058.13001, Git hash:master @ eaa901528453bac5a3cfc23321bdf4d767238d34)
License type: Commercial, build 2024-02-27
License details: LAN Zoo Network Node

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA T1000 8GB (NVidia) Memory: 8GB, Driver date: 3-14-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 538.49
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel(R) UHD Graphics 750 (Intel) Memory: 1GB, Driver date: 5-26-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-14-2024
Driver Version: 31.0.15.3849
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24058.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

This condition becomes quite uncomfortable when switching to the black interface.

Thank you.