A referenced element count not be found

Edit: this is in response to Japhy’s quoted post above.
I believe this is dependant on what version of Autodesk Desktop connector is installed. After ~ version 14.8 it changes the names of directories from BIM360 to ACCDOCS.

I can confirm I am using an older version of desktop connection which is still using BIM360 directories when getting the issue and should not be related.

1 Like

These files are now on a local server, not associated to BIM360 in any way.

I’ll test out Eshan’s link fix (see BIM360 Linked Revit Models thread above) on your files. Fix will be in the next daily build & next weeks RC.

@Japhy did you manage to resolve this?

No, we were able to reproduce after Ehsan’s link fix in 1.4 and it’s now in Kike’s hands.

I’ll let you know when the fix is in.

The issue is that Building A was saved as Building B (or vice versa) the result being is they have the same internal DOC id. No behind the scenes fix it looks like, we are testing a few things.

Linking into a new file and binding is one option, but really depends on the workflow you have going.

@kike have you seen this post (and linked posts) on the same issue: unique ID for project - Autodesk Community

@kike any update with this?

@parametricmonkey1 What about a warning like this?

@kike Yes I think that would work. Is this in the latest daily build?

However, could this cause any other issues - maybe with BIM360? I’m still not sure what the document ID is used for and why Autodesk allows two models to have identical IDs despite having different file names/paths.

@kike can you confirm if this has been added yet and to which version.

Still not.
It will be included in v1.5

Thanks. What’s the scheduled date for v1.5?

In the meantime, is there a way to change the Doc ID manually?

Hi @kike any update with this?

@kike any update on this? I see v1.5 has been released but can’t see any release notes.

Paul, I tested on your files on a 1.5 build last week and didn’t get the warning. The SDK is really close, so hopefully any release now.

Hi @Japhy, I still have the same issue with Revit 2020 and RIR ver. 1.5.8101.24584.
Deleting the Revit link and creating a new one with the same model permit the Grasshopper component to work correctly, but in this way we loose al the view template settings…
Is there another work-around to solve this problem? Thanks in advance

This is still an issue and under consideration of how to get the workaround stable. The problem is where to hold the newly created unique value.

1 Like

@Japhy @kike I’m on v1.8 daily build and I don’t believe the non unique ID feature has been enabled yet. Any update with this?

Hi @parametricmonkey1,

To fix this we need to modify the way we reference elements froms linked documents so it will be part of a major change.

Hopefuly as a v1.x but maybe we need to break things and should go into a 2.x.