A referenced element count not be found

Can I send you the model to test? Not working for me…

Sure thing, just put me as the recipient. Japhy @ mcneel.com

Thanks @Japhy will send shortly.

I’m not sure what is going on.

If I use the model I have and reference the linked model, it fails (Set multiple linked graphical elements)
If I remove the link and relink the model and reference it, it fails.
If I start a new project and link in the model, it works.

The file may have originated from BIM360. Could this ‘setting’ be embedded into the model somewhere and therefore RIR is rejecting it?

There doen’t appear anything special with the model - just a workshared model on local drive. No design options enabled. I’ve tried with and without shared coordinates. Phase mapping is the same in both models.

Any other thoughts as to why this might be failing?

@Japhy did you manage to get this to work?

I’ve managed to repeat the issue. Something is definitely different about Building B.

So does this mean the issue is being escalated? Others have also reported this issue 2 weeks ago.

It may be related to this as well, it looks like Autodesk has changed names in a few places.

Edit: this is in response to Japhy’s quoted post above.
I believe this is dependant on what version of Autodesk Desktop connector is installed. After ~ version 14.8 it changes the names of directories from BIM360 to ACCDOCS.

I can confirm I am using an older version of desktop connection which is still using BIM360 directories when getting the issue and should not be related.

1 Like

These files are now on a local server, not associated to BIM360 in any way.

I’ll test out Eshan’s link fix (see BIM360 Linked Revit Models thread above) on your files. Fix will be in the next daily build & next weeks RC.

@Japhy did you manage to resolve this?

No, we were able to reproduce after Ehsan’s link fix in 1.4 and it’s now in Kike’s hands.

I’ll let you know when the fix is in.

The issue is that Building A was saved as Building B (or vice versa) the result being is they have the same internal DOC id. No behind the scenes fix it looks like, we are testing a few things.

Linking into a new file and binding is one option, but really depends on the workflow you have going.

@kike have you seen this post (and linked posts) on the same issue: unique ID for project - Autodesk Community

@kike any update with this?

@parametricmonkey1 What about a warning like this?

@kike Yes I think that would work. Is this in the latest daily build?

However, could this cause any other issues - maybe with BIM360? I’m still not sure what the document ID is used for and why Autodesk allows two models to have identical IDs despite having different file names/paths.

@kike can you confirm if this has been added yet and to which version.

Still not.
It will be included in v1.5

Thanks. What’s the scheduled date for v1.5?

In the meantime, is there a way to change the Doc ID manually?