::a r a b i c texts::


#1

Hi all,
How can I use Arabic texts in Rhino 6, is there any plugins or adds-on through Grasshopper can achieve this?
As I also do have some AutoCAD and other format files that I import into Rhino, but Rhino seems not supporting Arabic texts as each of the letters are not connected.
It’s an urgent project to complete, so starving for a solution :wink:
Thanks in advance!
Elshar


(Brian Gillespie) #2

Hi Elshar,

Unfortunately, Rhino doesn’t support right-to-left reading languages right now, including Arabic and Hebrew. I’m sorry.


#3

Does Mcneel have any plans to make it possible anytime soon (maybe in V7)?


(Brian Gillespie) #4

We don’t have the roadmap for Rhino 7 figured out yet, so I can’t say for sure.


(Litwinaa) #5

Hello Elshar,

A limited work around that might help you in some situations is that you can try to paste into the Rhino text tool text box some text you want.

Thank you,
Andy


#6

Hello Andy

,
I just tried paste some texts, but the result still the same.


(Litwinaa) #7

Hello Elshar,

What type face / font are you using ?

Thank you,

Andy


(foreigner) #8

Hey @ Elshar
You can use this definition in Gh Rhino 5 . test .

Text Maker.gh (11.1 KB)


#9

Hi Andy,
I tried many of the usual Arabic fonts that I use.
Is there a specific font to do this?
Thanks,
Elshar


#10

Hey @foreigner,
It seems I cannot load Grasshopper in Rhino V5 any more :frowning: . I tried it in Grasshopper in Rhino V6 it ends up with the same result as posted above!
Thanks,
Elshar


(Litwinaa) #11

Hello Elshar,

I do not know if there is a “specific” type face /font to use but try Times New Roman. Please let me know the results.
Thank you, Andy


(foreigner) #12

That just use gh in rhino 5


#13

HI Andy,
I tried Times New Roman and other Arabic fonts, but I guess the font always set back to Arial. And in the properties panel I get this…


(Nathan 'jesterKing' Letwory) #14

The unicode points showing instead of the intended is fixed in 6.5 release candidate


#15

Hi Nathan,
I guess I have the latest update here …

Rhino 6 SR5 2018-5-12 (Rhino 6, 6.5.18132.5131, Git hash:master @ b8b8945d46018b7f175f54f1e384ede46df9745d)
Licence type: Evaluation, build 2018-05-12
License details: Stand-Alone
Expires on: 2018-07-25

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: THEENDS

GeForce 840M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 397.64)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-7-2018
Driver Version: 24.21.13.9764
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB


(Nathan 'jesterKing' Letwory) #16

Let me double-check if I got the version correct. I did test the fix for this recently.


(Nathan 'jesterKing' Letwory) #17

SOrry, I should’ve written 6.6. The fix is in our codebase, but not in the stabilizing branch for the upcoming 6.5. In (hopefully) a few weeks, with the release of final 6SR5 there’ll be a 6.6 release candidate.

This is the bug report: https://mcneel.myjetbrains.com/youtrack/issue/RH-46070


#18

That sounds great!
And also, can the panel in the top be hidden too while I am in Fullscreen mode?!


(Nathan 'jesterKing' Letwory) #19

I’ll leave that to @pascal to give an opinion on.


#20

And I also wish to get with each release update I install, a note file of the fixed issues within this update. As usually I don’t seem to have any issues with the current update but when I update to the upcoming release I end with issues I don’t have in the previous update!

Thanks,
Elshar!