A Lot of troubles with Display Modes

Many problems occur when you combine GH Custom Preview with RH Material and switch between Shaded/Rendered (and probably other) modes and also try to change Environments

Rhino 7.6.21124.9001


Rhino 7 SR6 2021-5-4 (Rhino 7, 7.6.21124.09001, Git hash:master @ 1a9a92254a9f347268c4c9c7f2dec50bcd90215e)
License type: Edukacyjna, build 2021-05-04
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [91% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 4-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.31
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-8-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Program Files\Rhino WIP\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\USER\Desktop\Crayon\unpacked 1.1.1\Crayon.rhp “Crayon”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”
C:\Users\USER\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.0\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\USER\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”
C:\Users\USER\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\1.0.0\Substance.Win.rhp “SubstanceImporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21124.9001
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino WIP\Plug-ins\NamedPositions.rhp “Named Position”

Slightly different issue but also about the display. Lately, Rendered mode has many glitches that are not always easy to reproduce. Even worse that Shaded mode often blinks and sometimes goes completely wild and geometry starts to reflect other geometries.

some videos:

Captured another one (in Shaded mode), probably the most disturbing. Locking worksession layers causes the problem, which is a pity, because I really need to keep them locked.

Custom Display mode with AO Shadows

I really like that many things can be customized in Display Modes and I extensively use SetObjectDisplayMode to extract area of interest from the scene. But many bugs and performance issues are absolute showstoppers and often they force me to take couple of steps back just when I tought I got my nice Display Mode ready.

Hello - there is not a lot we can do without a file and display modes that show the problem. Are objects very far from the world origin? Please also run the SystemInfo command in Rhino and copy/paste the results here.


Hello, I posted System Info in the previous post, please click on the triangle to unroll it.

World Origin is in the middle of the screen on many of my videos, so that’s not an issue.
The tricky part is that sometimes I try to prepare a minimal file to show the problem and it no longer exists… If I will catch it in one file then I will send it to you.

Hi Jakub - I see - I would see if there is any change if the non-default plug-ins are disabled and Rhino restarted.


Unfortunately, disabling plugins that do not ship with Rhino didn’t resolve this problem.

I just uploaded the zip file using Rhino - Upload to Support
Inside you will find a rhino file and two .ini files with display settings

Please check if the upload was correctly made.

this is how file looks just after open on my computer:

Hi Jakub - thanks, the ini files are the thing here - in the Shaded mode, ‘Use advanced gpu lighting’ seems to be the bad thing - uncheck that setting (this may well be a bug that needs looking into, thanks for pointing it out) and in the AO rendered mode, you have the shadow ‘bubble’ set to maximum - if you set that to None, it will stop doing that ‘thing’.


Thank you for the help Pascal.

I’m not sure if I have files from my first post, from March. They seem to have different issues. Maybe someone else will spot them too.

Best Regards