7 vs 5 toolbars and tabs

Hello. I have been Rhino 5 user for awhile and been satisfied that it is clear and easy to use. Now we got Rhino 7 and it was a huge disappointment. All toolbars and tabs are blurry and graphics are like it ist cheap copy from original, it looks poor and unclear.
I use win 10 and tried everything in windows but nothing helps. “Upgrade” to 7 was totally mistake. :unamused:


Hi @Campnou_Rhino
As you can probably imagine, this is of course not the intended look. First thing to do is to run the SystemInfo command in Rhino and post the result here. It could be a graphics card driver issue, eg. the driver being out-of-date. Rhino 7 demands a lot more from the graphics card, so it’s important to keep drivers up-to-date.
There’s also Windows’ own screen scaling options that will sometimes mess with the look of things. By right-clicking on your Rhino shortcut and going to Properties>Compatibility I think you can turn off or change the scaling or DPI settings for Rhino specifically - but start with the system info :slight_smile:
HTH, Jakob

Ok, thank you for response. :slightly_smiling_face:
Here is what it says:

Rhino 7 SR22 2022-9-12 (Rhino 7, 7.22.22255.05001, Git hash:master @ 196b1bc7dd093321e28dcc7a2bb8709a9bebe12d)
License type: Commercial, build 2022-09-12
License details: Stand-Alone

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 12-29-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context 21.30.40.05 30.0.13040.5001
> Integrated accelerated graphics device with 5 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-29-2021
Driver Version: 30.0.13040.5001
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Hi @Campnou_Rhino
Start by checking for an updated driver. There might also be either icon size or display scaling involved. What resolution are you running on your displays, what is your scaling (if any) and what size icons do you have in Rhino options>Toolbars>Size and Styles?
Other than that, running Rhino 7 with 2 screens on a 1GB card is roughly 7GB’s of VRAM away from being a great idea. The recommendation for V7 calls for a minimum of 4GB pr. screen. As I mentioned, V7 is a lot more taxing on the graphics card than V5 was/is.
-Jakob

Ok, thanks. :+1:
Icons are medium and not any scaling changed. Display resolution is recommended (1920x1080) on secondary monitor. This works much better on laptops itegrated screen.