3DConnexion SpaceMouse buttons stopped working

I have been using the 3D SpaceMouse Pro Wireless in Rhino …/4/5/6 for years, but it stopped working.

After hours of trying newer and older drivers, erasing registry entries, deleteting the configs
in \AppData\Roaming and \Local, I still have these two issues:

Rhino 5
Although the buttons are working, I cannot remap anything because
the plugin’s button mapping table is empty:

Well, how do I get that back?

Rhino 6
Basically working (knob and buttons), but what’s the right place to add
the missing commands?
As an example: The German “delete” (Löschen) command is not available:

Any ideas?

@Markus, can you assist here?

Rhino 5 SR14 64bit:
With the latest 3Dconnexion driver (10.5.10) I have Rhino 5 working with a SpaceMouse Pro Wireless in both German and English and can assign commands to buttons… Does wiring the SMPW change anything?

Rhino 6:
Rhino commands cannot as such be assigned to 3DMouse buttons. What can be assigned are the Rhino toolbar buttons. For commands that are not on a toolbar you have a couple of choices: either assign the command to a keyboard button and then create a macro to the keyboard button in the 3Dconnexion Properties UI, or create a macro in the 3Dconnexion Properties UI for the command itself.
For the “Delete” command you may have other alternatives: assign the delete key macro to a button or assign the ‘Cut’ (Ausschneiden) command.

Rhino 6:
Solved. Yep, found the file where the IDs are stored and
added a custom “Löschen” command.

Rhino 5:
After many hours of debugging and testing, I finally found out why
it isn’t working, although I did not manage to find a solution yet
or understand what exactly led to this situation.

I have a SpaceMouse Pro Wireless.

  • Operation with USB dongle: not working; as shown in the 1st post’s image
  • Operation with cable, yep, working:


In both cases, the 3DConnexion application clearly shows “SpaceMouse Pro Wireless”,
but for whatever reason, Rhino 5 thinks that’s a different device, without buttons…

I actually used it with the USB dongle right from the first day and I never had any problems.

Guess I’m going to contact the 3DConnexion support, but if any of you has a Pro Wireless/
Rhino 5 setup (and is reading this), could you please be so kind and post your



I spent so much time on this issue that I think it might be worse to write
about how to “emergency-fix” that (without fixing the root cause):

In the Windoze registry editor, browse, with Rhino closed, to


With a little luck, the search term “V3DK_” might directly lead you to the settings below.
If not, search for “3DConnexion” and you’ll find a GUID related to the plug-in, e.g.:


Remember that GUID (dca0db8d-844c-48d6-ba97-f5595fe6afdb) or use it as a search term and find the 3DConnexion settings at:

Computer\HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Plug-ins\dca0db8d-844c-48d6-ba97-f5595fe6afdb\Settings

Except for the keyboard mappings, radial menus, etc…, they’re all here:

[HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Plug-ins\dca0db8d-844c-48d6-ba97-f5595fe6afdb\Settings]

"Pan Zoom"="1"
"Single Axis Filter"="0"
"Navigation Mode"="0"
"Lock Horizon"="0"
"Center of Rotation"="1"
"Default Center of Rotation"="0"
"Selection Follower"="1"
"Pivot Visibility"="2"
"V3DK_MENU"="! _SpaceMouse _Popup_Menu"
"V3DK_FIT"="! _SpaceMouse _Zoom_Extents"
"V3DK_TOP"="! _SpaceMouse _Top_View"
"V3DK_LEFT"="! _SpaceMouse _Left_View"
"V3DK_RIGHT"="! _SpaceMouse _Right_View"
"V3DK_FRONT"="! _SpaceMouse _Front_View"
"V3DK_BOTTOM"="! _SpaceMouse _Bottom_View"
"V3DK_BACK"="! _SpaceMouse _Back_View"
"V3DK_ROLL_CW"="! _SpaceMouse _Roll_CW"
"V3DK_ROLL_CCW"="! _SpaceMouse _Roll_CCW"
"V3DK_ISO1"="! _SpaceMouse _Iso_View_1"
"V3DK_ISO2"="! _SpaceMouse _Iso_View_2"
"V3DK_6"="! _Properties"
"V3DK_9"="! _PointsOff"
"V3DK_ROTATE"="! _SpaceMouse _Rotate"
"V3DK_PANZOOM"="! _SpaceMouse _Pan_Zoom"
"V3DK_DOMINANT"="! _SpaceMouse _Dominant"
"V3DK_PLUS"="! _SpaceMouse _Increase_Speed"
"V3DK_MINUS"="! _SpaceMouse _Decrease_Speed"
"V3DK_SPIN_CW"="! _SpaceMouse _Spin_CW"
"V3DK_SPIN_CCW"="! _SpaceMouse _Spin_CCW"
"V3DK_TILT_CW"="! _SpaceMouse _Tilt_CW"
"V3DK_TILT_CCW"="! _SpaceMouse _Tilt_CCW"

From what I tested, this is definitely the best place to edit the settings and
they’ll also show up in the 3DxWare application.

Just a thought: maybe the SMPW is not paired to the receiver for some reason.
You might like to see if running ‘3Dconnexion Pairing’ helps at all.