3d mouse slows to a hlaf upon close inspection of objects

Hi there. I have a 3d mouse and it works very well in the rhino environment until you get too close to an object where it slows to a complete halt. it is possible to make a quick fix by clicking on an object and using the ZS command but it really is a bore having to do this all the time and makes traversing through the digital environment a lot less smooth as it could be. I know this topic has been covered with regards to traditional mouse navigation but is there anything i can do to rid myself of this problem for good with my 3d mouse? Thanks for reading.

Using the 3d mouse connexion and I do not think there is a way to avoid the problem that you describes .
My solution has been to set a button with the “zoom command target”.
When I zoom in on an object and it happens the problem you describe, we press the set button and I can still get closer to the object.

1 Like

yes currently i have set one of my buttons to the ‘ZS’ command which focuses the zoom onto an object and allows for closer inspection but if the object is one large one with nothing specific to focus on it makes that solution invalid.
another solution is to use the viewport properties command and then change the perspective to parallel. this allows closer zooming but doesnt allow you to rotate(with your 3d mouse)

That’s why you should use ZT - for Zoom Target - instead of ZS.

i don’t seem to have that command available in my mac version of the software unfortunately.

You might have to make a shortcut yourself but the option should be available according to the help file for MacRhino:

1 Like

yes it is there indeed. is it possible to make this accessible from the command line? there is an option for making a shortcut and for accessing it using scripting but none of these make it accessible from the command line (so i can asign it to my 3d mouse button).

HI Danny

Zoom Target


1 Like

T’riffic. Thanks for the help folks.

It would be nice if this could be corrected fundamentally… So you can just drive the screen around the model endlessly… I don’t fully understand what’s happening and why the zoom gets wonky / slow movement but it would sure be nice if it could be corrected. I’ve never really fully committed to using the 3d mouse and this is why. It’s a nuisance having to constantly fix the zoom. (windows)