3d Conexxion Space Mouse

3d Connexxion Space mouse does not correctly recognize Rhino 6 separately from Rhino 5.

I noticed this as well, that the Space Mouse command center indicates v5 in both 5 and 6…however the ‘invert’ controls for the various axis seem to be flipped (so to speak) between the two versions. In other words, anything I have not inverted in v5 acts as if it is inverted in v6, and vice versa. Moving between v5 and v6 requires reconfiguring the controls…

yep i noticed the same thing

Hi all - I don’t use this thing in real life but I have a 3dConnexion deal to test with - can you give me a blow by blow, for idiots, for how to reproduce the problem you’re seeing?
thanks,

-Pascal

hey Pascal-
so reproduction shouldn’t be hard. i’ve been using my space mouse in rhino 5, and when i loaded rhino 6, all of the commands are reversed (or something else). the issue is that i can’t seem to set separate settings for rhino 6, as 3d Connexxion doesn’t seem to see it as a different application from rhino 5.

Hello - OK, thanks - I only have a dinky two button deal - maybe my device is just not fancy enough to see what you’re seeing. Both buttons fire off the same commands in 5 and 6. The plug-ins for 5 and 6 are separate files…

-Pascal

I have a spacepilot pro on my desk. I’ll check tomorrow in the office if I can reproduce.

Excellent, thanks @nathanletwory

-Pascal

this is what i have
https://www.3dconnexion.com/products/spacemouse/spacemousewireless.html

I am assuming I still would see something similar, even though I have dated hardware. My SpacePilot Pro is like the SpaceMouse Enterprise. In this video I am using it while sculpting in Blender.

@daweissman. As far as I can tell the button mappings are the same between V5 and V6 on my SpacePilot Pro. I don’t know if it makes any difference, but I didn’t install the driver for the device - it should work without just fine.

I don’t know if any of our developers has the same device on their desk to test with.

This is an old thread, but this exact problem seems to have reappeared when running a SpaceMouse Enterprise on V6 and V7WIP. The 3dConnection Command Center doesn’t differentiate between them (It sees them both as ‘Rhinoceros’), but the 2 versions of Rhino require different settings. For V6 the 6 axis control directions have to have ‘reverse’ checked, but for V7WIP they must all have ‘reverse’ unchecked.

I am experiencing some reverse rotation trouble with my Space Mouse with V7 WIP.
It seems to be related to if the file was originally created in V6 and then opened in V7 WIP or if the file was originally created in V7 WIP.

Files created in V6 rotate correctly in V6 and backwards when opened with V7 WIP.
Note this happens in V7 WIP while the file is still a V6 file. Saving to V7 WIP does not correct this.

Files created in V7 WIP rotate correctly in V7 WIP.
Saving back to V6 and opening with V7 WIP the model still rotates correctly.
Opening the V6 file that was originally created in V7 WIP with V6 the model still rotates correctly.

So it seems the reverse action is limited to files that were created in V6 then opened in V7 WIP. However as this is nearly all the files I am currently actively using it makes exploring V7 WIP inconvenient.

Can you suggest any solution that will allow me to change the rotation of V6 files when opened in V7 WIP? Have so far only investigated this with V7 WIP on the Mac. I may have a chance to have a go at this again tomorrow on a Windows machine.

Digging deeper-seems the problem may be limited to files created in V6. I dug out some old files that are still formatted for V3, V4 and V5 and they rotate fine in V7 WIP.

Version 6 (6.24.20079.23332, 2020-03-19) Mac
Version 7 WIP (7.0.20112.14506, 2020-04-21) Mac

edit: I have become so accustomed to using a Space Mouse that I don’t normally rotate a model any other way. But it just occurred to me that maybe the problem was not related to the Space Mouse at all, so I tried rotating the V6 models in V7 WIP with the track pad on my MacBook. Sure enough the same rotation problem I described above happens with the track pad. So it seems the the problem will not be solved by simply using a track pad instead of the Space Mouse.

edit 2- just installed Rhino7 WIP on a Dell workstation running Windows 10 and the Space Navigator rotates models correctly in both Rhino 6 and Rhino7 WIP