1st Character Command Line Entry Selects a Layer


#1

New thread as requested by Marlin. Not sure if this is unique to MacRhino (v514) or if this also occurs in WinRhino. Can’t test this since my Windows side needs to be reinstalled. Perhaps a Windows user can test this?


#2

No, on the Windows side typing a letter even when the cursor is over the layers panel goes to the command line.

–Mitch


#3

Nice to know. Thanks Mitch. Looks like a current glitch in MacRhino only.

~Dave


#4

yeah, this happens to me a lot too (do something in the layers panel which brings focus to it… try to use the command line but a layer name starting with the same letter is highlighted instead)…

i’m not sure if it’s an easy fix as i think the way mac handles window/panel focus is different than with windows but hopefully it’s fixable none-the-less…


#5

The Windows version has some designed-in quirkiness for those of us who happen to dock left. As soon as you take a short cut over the layer panel aiming for your chosen command, the auto complete drop-down is cancelled, so you have to remember to go around the top, I always forget…


#6

The same thing happens with other menu’s in the right side bar, for instance CPlanes, NamedViews.

If you would like to keep this function, I’d suggest using a mouse over check. If your mouse cursor is hovering over the layer panel it does trigger, if it’s in the contruction area it excutes the short cut or goes directly to the command line.

Thanks.


#7

Sometimes if a window is open on top of Rhino (Win7), email for example, the email window will suddenly lose focus and disappear behind Rhino. I just realised this happens when the mouse pointer slips onto the docked layer window of the Rhino behind. Does anyone else see this?


(Marlin Prowell) #8

The issue is keyboard focus, and keyboard focus on OS X is entirely different from Windows. For example, the location of the mouse cursor does not affect where key strokes are delivered.

There are 3 different places where you can display the layers panel. I’m certain that you are not describing the layers popover that you get when you click the tool bar button, but I cannot tell whether you are describing behavior in the floating layers panel or the layers panel in the main window sidebar. Let me know which one you are using.

Also, you are performing some action before you start typing. That step apparently has the side effect of shifting keyboard focus to the layer panel. Tell me what that action is.


#9

This issue was happening with the layer panel docked either to the right or left sidebars (windows version not OSX, sorry wrong thread), the floating panel was fine. As the mouse pointer passed over (no click) the layer panel, although Rhino was behind the window I was working in, explorer for example, Rhino would take the focus to the commandline and explorer would disappear behind Rhino.

The thing is, all is ok today so I’m not sure what triggers the event. Next time it happens I’ll note what I was doing leading up to the problem.


#10

Hi @marlin… Any thoughts for MacRhino on this one?

To add some additional, and related, info: I’ve also noticed some oddities with keyboard shortcuts immediately after working in the layers panel without first clicking in a modeling window. I’m having difficulty duplicating this situation reliably, but have noticed a keyboard shortcut starting a command, but when using another key to specify an option for the command this, too, will scroll through the layers panel instead of selecting the option for the command. (Have noticed this for CPlane and Line, but am unable to duplicate now. Must be some other step involved).

Sorry for the vagueness—will try to predictably replicate and describe the steps involved.

~Dave


#11

to see this behavior: (at least, the one i was talking about earlier… i’m pretty sure it’s what others are talking about too)

• open a new model using any of the standard templates (they’ll all have a default layer then Layer01 - Layer05)
• using the right sidebar layer panel, create a new layer and name it ‘Test’… make this your active layer by clicking on the radio button next to it’s name in the layers panel (which brings focus to the panel)
• start typing the command Line
• notice the ‘L’ key has caused ‘layer 01’ to highlight instead of calling the command search

• using the same setup as above, make Layer 01 active
• start typing the command TextObject
• notice the ‘T’ key has caused the layer ‘Test’ to highlight.


• try the same thing with the Join command… it works fine since none of the layers begin with the letter ‘J’
• also, if you happen to have the layer ‘Test’ highlighted in blue, any of the T commands will work as expected…
• note- the entire layers panel is outlined in a faint blue when focus is on it.

• something similar also happens when using the top toolbar layer dropdown except it’s not as big a deal there since you can’t call the command search while that panel is active… so, at least, you’re not unexpectedly starting commands.


(Marlin Prowell) #12

OK, I see this. Somehow the extra step of clicking the active layer radio button changes keyboard focus. If you just type the layer name and press return, typing commands work fine.

I’ve entirely removed the ability to select a layer name by typing, and that seems to fix this problem. This will be in the next WIP release.


(Marlin Prowell) #13

@BrianM The similar problem you are describing with Windows Rhino is specific to MS Windows, and I don’t know the MS Windows keyboard handling well enough to work on this. The changes I just made are specific to the Mac.

I suggest you start a new thread in the Rhino for Windows category, reference this thread for your previous posts, and then continue the conversation there.


#14

Thanks for disabling this for now, Marlin!